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1 Getting Started

Product Overview

In this section...

“Features” on page 1-2

“Expected Users” on page 1-3

Features
The Bioinformatics Toolbox™ product extends the MATLAB® environment
to provide an integrated software environment for genome and proteome
analysis. Scientists and engineers can answer questions, solve problems,
prototype new algorithms, and build applications for drug discovery and
design, genetic engineering, and biological research. An introduction to these
features will help you to develop a conceptual model for working with the
toolbox and your biological data.

The Bioinformatics Toolbox product includes many functions to help you with
genome and proteome analysis. Most functions are implemented in M-code
(the MATLAB programming language) with the source available for you to
view. This open environment lets you explore and customize the existing
toolbox algorithms or develop your own.

You can use the basic bioinformatic functions provided with this toolbox
to create more complex algorithms and applications. These robust and
well-tested functions are the functions that you would otherwise have to
create yourself.

Toolbox features and functions fall within these categories:

• Data formats and databases — Connect to Web-accessible databases
containing genomic and proteomic data. Read and convert between
multiple data formats.

• Sequence analysis — Determine the statistical characteristics of a
sequence, align two sequences, and multiply align several sequences.
Model patterns in biological sequences using hidden Markov model (HMM)
profiles.

• Phylogenetic analysis— Create and manipulate phylogenetic tree data.
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Product Overview

• Microarray data analysis— Read, normalize, and visualize microarray
data.

• Mass spectrometry data analysis — Analyze and enhance raw mass
spectrometry data.

• Statistical learning — Classify and identify features in data sets with
statistical learning tools.

• Programming interface — Use other bioinformatic software (BioPerl
and BioJava) within the MATLAB environment.

The field of bioinformatics is rapidly growing and will become increasingly
important as biology becomes a more analytical science. The toolbox provides
an open environment that you can customize for development and deployment
of the analytical tools you will need.

• Prototype and develop algorithms— Prototype new ideas in an open
and extensible environment. Develop algorithms using efficient string
processing and statistical functions, view the source code for existing
functions, and use the code as a template for customizing, improving,
or creating your own functions. See “Prototyping and Development
Environment” on page 1-19.

• Visualize data — Visualize sequences and alignments, gene expression
data, phylogenetic trees, mass spectrometry data, protein structure,
and relationships between data with interconnected graphs. See “Data
Visualization” on page 1-20.

• Share and deploy applications — Use an interactive GUI builder to
develop a custom graphical front end for your data analysis programs.
Create standalone applications that run separately from the MATLAB
environment. See “Algorithm Sharing and Application Deployment” on
page 1-20.
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Expected Users
The Bioinformatics Toolbox product is intended for computational biologists
and research scientists who need to develop new algorithms or implement
published ones, visualize results, and create standalone applications.

• Industry/Professional— Increasingly, drug discovery methods are being
supported by engineering practice. This toolbox supports tool builders
who want to create applications for the biotechnology and pharmaceutical
industries.

• Education/Professor/Student— This toolbox is well suited for learning
and teaching genome and proteome analysis techniques. Educators
and students can concentrate on bioinformatic algorithms instead of
programming basic functions such as reading and writing to files.

While the toolbox includes many bioinformatic functions, it is not intended
to be a complete set of tools for scientists to analyze their biological data.
However, the MATLAB environment is ideal for rapidly designing and
prototyping the tools you need.
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Installation

Installation

In this section...

“Installing” on page 1-5

“Required Software” on page 1-5

“Optional Software” on page 1-6

Installing
Install the Bioinformatics Toolbox software from a DVD or Web release using
the MathWorks™ Installer. For more information, see the Installation Guide
for your platform.

Required Software
The Bioinformatics Toolbox software requires the following MathWorks
products to be installed on your computer.

Required Software Description

MATLAB Provides a command-line interface and integrated
software environment for the Bioinformatics
Toolbox software.

Version 3.4 of the Bioinformatics Toolbox software
requires MATLAB Version 7.9 on the Release
2009b DVD.

Statistics Toolbox™ Provides basic statistics and probability functions
used by the functions of the Bioinformatics
Toolbox software.

Version 3.4 of the Bioinformatics Toolbox software
requires Statistics Toolbox Version 7.2 on the
Release 2009b DVD.
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Optional Software
MATLAB and the Bioinformatics Toolbox software environment is open and
extensible. In this environment you can interactively explore ideas, prototype
new algorithms, and develop complete solutions to problems in bioinformatics.
MATLAB facilitates computation, visualization, prototyping, and deployment.

Using the Bioinformatics Toolbox software with other MATLAB toolboxes and
products will allow you to do advanced algorithm development and solve
multidisciplinary problems.

Optional Software Description

Parallel Computing
Toolbox™

Perform parallel bioinformatic computations on
multicore computers and computer clusters. For
an example of batch processing through parallel
computing, see the Batch Processing of Spectra
Using Distributed Computing demo.

Signal Processing
Toolbox™

Process signal data from bioanalytical
instrumentation. Examples include acquisition
of fluorescence data for DNA sequence analyzers,
fluorescence data for microarray scanners, and
mass spectrometric data from protein analyses.

Image Processing
Toolbox™

Create complex and custom image processing
algorithms for data from microarray scanners.

SimBiology® Model, simulate, and analyze biochemical systems.

Optimization
Toolbox™

Use nonlinear optimization to predict the
secondary structure of proteins and the structure
of other biological macromolecules.

Neural Network
Toolbox™

Use neural networks to solve problems where
algorithms are not available. For example, you
can train neural networks for pattern recognition
using large sets of sequence data.

Database Toolbox™ Create your own in-house databases for sequence
data with custom annotations.
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Optional Software Description

MATLAB®

Compiler™
Create standalone applications from MATLAB
GUI applications, and create dynamic link
libraries from MATLAB functions to use with any
programming environment.

MATLAB® Builder™
NE

Create COM objects to use with any COM-based
programming environment.

MATLAB Builder JA Integrate MATLAB applications into your
organization’s Java™ programs by creating a Java
wrapper around the application.

MATLAB Builder EX Create Microsoft® Excel® add-in functions
from MATLAB functions to use with Excel®

spreadsheets.

Spreadsheet Link™
EX

Connect Microsoft Excel with the MATLAB
Workspace to exchange data and to use MATLAB
computational and visualization functions. For
more information, see “Using Spreadsheet Link
EX with Bioinformatic Data” on page 1-22.
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Features and Functions

In this section...

“Data Formats and Databases” on page 1-8

“Sequence Alignments” on page 1-10

“Sequence Utilities and Statistics” on page 1-11

“Protein Property Analysis” on page 1-11

“Phylogenetic Analysis” on page 1-12

“Microarray Data Analysis” on page 1-12

“Microarray Data Storage” on page 1-14

“Mass Spectrometry Data Analysis” on page 1-14

“Graph Theory Functions” on page 1-17

“Graph Visualization” on page 1-18

“Statistical Learning and Visualization” on page 1-18

“Prototyping and Development Environment” on page 1-19

“Data Visualization” on page 1-20

“Algorithm Sharing and Application Deployment” on page 1-20

Data Formats and Databases
The toolbox accesses many of the databases on the Web and other online data
sources. It allows you to copy data into the MATLAB Workspace, and read
and write to files with standard bioinformatic formats. It also reads many
common genome file formats, so that you do not have to write and maintain
your own file readers.

Web-based databases — You can directly access public databases on the
Web and copy sequence and gene expression information into the MATLAB
environment.

The sequence databases currently supported are GenBank® (getgenbank),
GenPept (getgenpept), European Molecular Biology Laboratory (EMBL)
(getembl), and Protein Data Bank (PDB) (getpdb). You can also access data
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from the NCBI Gene Expression Omnibus (GEO) Web site by using a single
function (getgeodata).

Get multiply aligned sequences (gethmmalignment), hidden Markov model
profiles (gethmmprof), and phylogenetic tree data (gethmmtree) from the
PFAM database.

Gene Ontology database — Load the database from the Web into
a gene ontology object (geneont.geneont). Select sections of the
ontology with methods for the geneont object (geneont.getancestors,
geneont.getdescendants, geneont.getmatrix, geneont.getrelatives),
and manipulate data with utility functions (goannotread, num2goid).

Read data from instruments — Read data generated from gene
sequencing instruments (scfread, joinseq, traceplot), mass spectrometers
(jcampread), and Agilent® microarray scanners (agferead).

Reading data formats — The toolbox provides a number of functions for
reading data from common bioinformatic file formats.

• Sequence data: GenBank (genbankread), GenPept (genpeptread), EMBL
(emblread), PDB (pdbread), and FASTA (fastaread)

• Multiply aligned sequences: ClustalW and GCG formats (multialignread)

• Gene expression data from microarrays: Gene Expression Omnibus (GEO)
data (geosoftread), GenePix® data in GPR and GAL files (gprread,
galread), SPOT data (sptread), Affymetrix® GeneChip® data (affyread),
and ImaGene® results files (imageneread)

• Hidden Markov model profiles: PFAM-HMM file (pfamhmmread)

Note The affyread function does not work on the Solaris™ platform.

Writing data formats — The functions for getting data from the Web
include the option to save the data to a file. However, there is a function to
write data to a file using the FASTA format (fastawrite).
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BLAST searches — Request Web-based BLAST searches (blastncbi), get
the results from a search (getblast) and read results from a previously saved
BLAST formatted report file (blastread).

The MATLAB environment has built-in support for other industry-standard
file formats including Microsoft Excel and comma-separated-value (CSV) files.
Additional functions perform ASCII and low-level binary I/O, allowing you to
develop custom functions for working with any data format.

Sequence Alignments
You can select from a list of analysis methods to compare nucleotide or amino
acid sequences using pairwise or multiple sequence alignment functions.

Pairwise sequence alignment — Efficient implementations of standard
algorithms such as the Needleman-Wunsch (nwalign) and Smith-Waterman
(swalign) algorithms for pairwise sequence alignment. The toolbox also
includes standard scoring matrices such as the PAM and BLOSUM
families of matrices (blosum, dayhoff, gonnet, nuc44, pam). Visualize
sequence similarities with seqdotplot and sequence alignment results with
showalignment.

Multiple sequence alignment — Functions for multiple sequence
alignment (multialign, profalign) and functions that support multiple
sequences (multialignread, fastaread, showalignment). There is also a
graphical interface (multialignviewer) for viewing the results of a multiple
sequence alignment and manually making adjustment.

Multiple sequence profiles— Implementations for multiple alignment and
profile hidden Markov model algorithms (gethmmprof, gethmmalignment,
gethmmtree, pfamhmmread, hmmprofalign, hmmprofestimate,
hmmprofgenerate, hmmprofmerge, hmmprofstruct, showhmmprof).

Biological codes — Look up the letters or numeric equivalents for
commonly used biological codes (aminolookup, baselookup, geneticcode,
revgeneticcode).
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Sequence Utilities and Statistics
You can manipulate and analyze your sequences to gain a deeper
understanding of the physical, chemical, and biological characteristics of
your data. Use a graphical user interface (GUI) with many of the sequence
functions in the toolbox (seqtool).

Sequence conversion and manipulation— The toolbox provides routines
for common operations, such as converting DNA or RNA sequences to amino
acid sequences, that are basic to working with nucleic acid and protein
sequences (aa2int, aa2nt, dna2rna, rna2dna, int2aa, int2nt, nt2aa, nt2int,
seqcomplement, seqrcomplement, seqreverse).

You can manipulate your sequence by performing an in silico digestion with
restriction endonucleases (restrict) and proteases (cleave).

Sequence statistics — Determine various statistics about a sequence
(aacount, basecount, codoncount, dimercount, nmercount, ntdensity,
codonbias, cpgisland, oligoprop), search for specific patterns within a
sequence (seqshowwords, seqwordcount), or search for open reading frames
(seqshoworfs). In addition, you can create random sequences for test cases
(randseq).

Sequence utilities—Determine a consensus sequence from a set of multiply
aligned amino acid, nucleotide sequences (seqconsensus, or a sequence
profile (seqprofile). Format a sequence for display (seqdisp) or graphically
show a sequence alignment with frequency data (seqlogo).

Additional MATLAB functions efficiently handle string operations with
regular expressions (regexp, seq2regexp) to look for specific patterns in a
sequence and search through a library for string matches (seqmatch).

Look for possible cleavage sites in a DNA/RNA sequence by searching for
palindromes (palindromes).

Protein Property Analysis
You can use a collection of protein analysis methods to extract information
from your data. You can determine protein characteristics and simulate
enzyme cleavage reactions. The toolbox provides functions to calculate various
properties of a protein sequence, such as the atomic composition (atomiccomp),
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molecular weight (molweight), and isoelectric point (isoelectric). You can
cleave a protein with an enzyme (cleave, rebasecuts) and create distance
and Ramachandran plots for PDB data (pdbdistplot, ramachandran). The
toolbox contains a graphical user interface for protein analysis (proteinplot)
and plotting 3-D protein and other molecular structures with information
from molecule model files, such as PDB files (molviewer).

Amino acid sequence utilities — Calculate amino acid statistics for a
sequence (aacount) and get information about character codes (aminolookup).

Phylogenetic Analysis
You can use functions for phylogenetic tree building and analysis. There is
also a GUI to draw phylograms (trees).

Phylogenetic tree data — Read and write Newick-formatted tree files
(phytreeread, phytreewrite) into the MATLAB Workspace as phylogenetic
tree objects (phytree).

Create a phylogenetic tree — Calculate the pairwise distance between
biological sequences (seqpdist), estimate the substitution rates (dnds,
dndsml), build a phylogenetic tree from pairwise distances (seqlinkage,
seqneighjoin, reroot), and view the tree in an interactive GUI that allows
you to view, edit, and explore the data (phytreetool or view). This GUI also
allows you to prune branches, reorder, rename, and explore distances.

Phylogenetic tree object methods — You can access the functionality
of the phytreetool GUI using methods for a phylogenetic tree object
(phytree). Get property values (get) and node names (getbyname). Calculate
the patristic distances between pairs of leaf nodes (pdist, weights)
and draw a phylogenetic tree object in a MATLAB Figure window as a
phylogram, cladogram, or radial treeplot (plot). Manipulate tree data by
selecting branches and leaves using a specified criterion (select, subtree)
and removing nodes (prune). Compare trees (getcanonical) and use
Newick-formatted strings (getnewickstr).

Microarray Data Analysis
The MATLAB environment is widely used for microarray data analysis,
including reading, filtering, normalizing, and visualizing microarray data.
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However, the standard normalization and visualization tools that scientists
use can be difficult to implement. The toolbox includes these standard
functions:

Microarray data — Read Affymetrix GeneChip files (affyread) and plot
data (probesetplot), ImaGene results files (imageneread), SPOT files
(sptread) and Agilent microarray scanner files (agferead). Read GenePix
GPR files (gprread) and GAL files (galread). Get Gene Expression Omnibus
(GEO) data from the Web (getgeodata) and read GEO data from files
(geosoftread).

A utility function (magetfield) extracts data from one of the microarray
reader functions (gprread, agferead, sptread, imageneread).

Microarray normalization and filtering — The toolbox provides a
number of methods for normalizing microarray data, such as lowess
normalization (malowess) and mean normalization (manorm), or across
multiple arrays (quantilenorm). You can use filtering functions to
clean raw data before analysis (geneentropyfilter, genelowvalfilter,
generangefilter, genevarfilter), and calculate the range and variance of
values (exprprofrange, exprprofvar).

Microarray visualization— The toolbox contains routines for visualizing
microarray data. These routines include spatial plots of microarray data
(maimage, redgreencmap), box plots (maboxplot), loglog plots (maloglog),
and intensity-ratio plots (mairplot). You can also view clustered expression
profiles (clustergram, redgreencmap). You can create 2-D scatter plots of
principal components from the microarray data (mapcaplot).

Microarray utility functions — Use the following functions to work
with Affymetrix GeneChip data sets. Get library information for a probe
(probelibraryinfo), gene information from a probe set (probesetlookup),
and probe set values from CEL and CDF information (probesetvalues).
Show probe set information from NetAffx™ Analysis Center (probesetlink)
and plot probe set values (probesetplot).

The toolbox accesses statistical routines to perform cluster analysis and
to visualize the results, and you can view your data through statistical
visualizations such as dendrograms, classification, and regression trees.
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Microarray Data Storage
The toolbox includes functions, objects, and methods for creating, storing, and
accessing microarray data.

The object constructor function, DataMatrix, lets you create a DataMatrix
object to encapsulate data and metadata from a microarray experiment. A
DataMatrix object stores experimental data in a matrix, with rows typically
corresponding to gene names or probe identifiers, and columns typically
corresponding to sample identifiers. A DataMatrix object also stores
metadata, including the gene names or probe identifiers (as the row names)
and sample identifiers (as the column names).

You can reference microarray expression values in a DataMatrix object the
same way you reference data in a MATLAB array, that is, by using linear or
logical indexing. Alternately, you can reference this experimental data by
gene (probe) identifiers and sample identifiers. Indexing by these identifiers
lets you quickly and conveniently access subsets of the data without having
to maintain additional index arrays.

Many MATLAB operators and arithmetic functions are available to
DataMatrix objects by means of methods. These methods let you modify,
combine, compare, analyze, plot, and access information from DataMatrix
objects. Additionally, you can easily extend the functionality by using
general element-wise functions, dmarrayfun and dmbsxfun, and by manually
accessing the properties of a DataMatrix object.

Note For more information on creating and using DataMatrix objects, see
“Working with DataMatrix Objects” on page 3-21.

Mass Spectrometry Data Analysis
The mass spectrometry functions preprocess and classify raw data from
SELDI-TOF and MALDI-TOF spectrometers and use statistical learning
functions to identify patterns.

Reading raw data — Load raw mass/charge and ion intensity data from
comma-separated-value (CSV) files, or read a JCAMP-DX-formatted file with
mass spectrometry data (jcampread) into the MATLAB environment.
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You can also have data in TXT files and use the importdata function.

Preprocessing raw data — Resample high-resolution data to a lower
resolution (msresample) where the extra data points are not needed. Correct
the baseline (msbackadj). Align a spectrum to a set of reference masses
(msalign) and visually verify the alignment (msheatmap). Normalize the
area between spectra for comparing (msnorm), and filter out noise (mslowess
and mssgolay).

Spectrum analysis— Load spectra into a GUI (msviewer) for selecting mass
peaks and further analysis.

The following graphic illustrates the roles of the various mass spectrometry
functions in the toolbox.
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Graph Theory Functions
Graph theory functions in the toolbox apply basic graph theory algorithms to
sparse matrices. A sparse matrix represents a graph, any nonzero entries in
the matrix represent the edges of the graph, and the values of these entries
represent the associated weight (cost, distance, length, or capacity) of the
edge. Graph algorithms that use the weight information will cancel the edge
if a NaN or an Inf is found. Graph algorithms that do not use the weight
information will consider the edge if a NaN or an Inf is found, because these
algorithms look only at the connectivity described by the sparse matrix and
not at the values stored in the sparse matrix.

Sparse matrices can represent four types of graphs:

• Directed Graph — Sparse matrix, either double real or logical. Row
(column) index indicates the source (target) of the edge. Self-loops (values
in the diagonal) are allowed, although most of the algorithms ignore these
values.

• Undirected Graph — Lower triangle of a sparse matrix, either double
real or logical. An algorithm expecting an undirected graph ignores values
stored in the upper triangle of the sparse matrix and values in the diagonal.

• Direct Acyclic Graph (DAG) — Sparse matrix, double real or logical,
with zero values in the diagonal. While a zero-valued diagonal is a
requirement of a DAG, it does not guarantee a DAG. An algorithm expecting
a DAG will not test for cycles because this will add unwanted complexity.

• Spanning Tree — Undirected graph with no cycles and with one
connected component.

There are no attributes attached to the graphs; sparse matrices representing
all four types of graphs can be passed to any graph algorithm. All functions
will return an error on nonsquare sparse matrices.

Graph algorithms do not pretest for graph properties because such tests
can introduce a time penalty. For example, there is an efficient shortest
path algorithm for DAG, however testing if a graph is acyclic is expensive
compared to the algorithm. Therefore, it is important to select a graph theory
function and properties appropriate for the type of the graph represented by
your input matrix. If the algorithm receives a graph type that differs from
what it expects, it will either:
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• Return an error when it reaches an inconsistency. For example, if you pass
a cyclic graph to the graphshortestpath function and specify Acyclic as
the method property.

• Produce an invalid result. For example, if you pass a directed graph to a
function with an algorithm that expects an undirected graph, it will ignore
values in the upper triangle of the sparse matrix.

The graph theory functions include graphallshortestpaths, graphconncomp,
graphisdag, graphisomorphism, graphisspantree, graphmaxflow,
graphminspantree, graphpred2path, graphshortestpath, graphtopoorder,
and graphtraverse.

Graph Visualization
The toolbox includes functions, objects, and methods for creating, viewing,
and manipulating graphs such as interactive maps, hierarchy plots, and
pathways. This allows you to view relationships between data.

The object constructor function (biograph) lets you create a biograph object to
hold graph data. Methods of the biograph object let you calculate the position
of nodes (dolayout), draw the graph (view), get handles to the nodes and
edges (getnodesbyid and getedgesbynodeid) to further query information,
and find relations between the nodes (getancestors, getdescendants,
and getrelatives). There are also methods that apply basic graph theory
algorithms to the biograph object.

Various properties of a biograph object let you programmatically change the
properties of the rendered graph. You can customize the node representation,
for example, drawing pie charts inside every node (CustomNodeDrawFcn). Or
you can associate your own callback functions to nodes and edges of the graph,
for example, opening a Web page with more information about the nodes
(NodeCallback and EdgeCallback).

Statistical Learning and Visualization
You can classify and identify features in data sets, set up cross-validation
experiments, and compare different classification methods.
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The toolbox provides functions that build on the classification and statistical
learning tools in the Statistics Toolbox software (classify, kmeans, and
treefit).

These functions include imputation tools (knnimpute), support vector machine
classifiers (svmclassify, svmtrain) and K-nearest neighbor classifiers
(knnclassify).

Other functions include set up of cross-validation experiments (crossvalind)
and comparison of the performance of different classification methods
(classperf). In addition, there are tools for selecting diversity and
discriminating features (rankfeatures, randfeatures).

Prototyping and Development Environment
The MATLAB environment lets you prototype and develop algorithms and
easily compare alternatives.

• Integrated environment — Explore biological data in an environment
that integrates programming and visualization. Create reports and plots
with the built-in functions for mathematics, graphics, and statistics.

• Open environment — Access the source code for the toolbox functions.
The toolbox includes many of the basic bioinformatics functions you will
need to use, and it includes prototypes for some of the more advanced
functions. Modify these functions to create your own custom solutions.

• Interactive programming language — Test your ideas by typing
functions that are interpreted interactively with a language whose basic
data element is an array. The arrays do not require dimensioning and
allow you to solve many technical computing problems,

Using matrices for sequences or groups of sequences allows you to work
efficiently and not worry about writing loops or other programming controls.

• Programming tools— Use a visual debugger for algorithm development
and refinement and an algorithm performance profiler to accelerate
development.

1-19



1 Getting Started

Data Visualization
You can visually compare pairwise sequence alignments, multiply aligned
sequences, gene expression data from microarrays, and plot nucleic acid and
protein characteristics. The 2-D and volume visualization features let you
create custom graphical representations of multidimensional data sets. You
can also create montages and overlays, and export finished graphics to an
Adobe® PostScript® image file or copy directly into Microsoft® PowerPoint®.

Algorithm Sharing and Application Deployment
The open MATLAB environment lets you share your analysis solutions with
other users, and it includes tools to create custom software applications.
With the addition of MATLAB Compiler software, you can create standalone
applications independent of the MATLAB environment, and, with the addition
of MATLAB Builder NE software, you can create GUIs and standalone
applications within other programming environments.

• Share algorithms with other users — You can share data analysis
algorithms created in the MATLAB language across all supported platforms
by giving M-files to other users. You can also create GUIs within the
MATLAB environment using the Graphical User Interface Development
Environment (GUIDE).

• Deploy MATLAB GUIs — Create a GUI within the MATLAB
environment using GUIDE, and then use MATLAB Compiler software
to create a standalone GUI application that runs separately from the
MATLAB environment.

• Create dynamic link libraries (DLLs) — Use MATLAB Compiler
software to create DLLs for your functions, and then link these libraries to
other programming environments such as C and C++.

• Create COM objects — Use MATLAB Builder NE software to create
COM objects, and then use a COM-compatible programming environment
(Visual Basic®) to create a standalone application.

• Create Excel add-ins — Use MATLAB Builder EX software to
create Excel add-in functions, and then use these functions with Excel
spreadsheets.

• Create Java classes — Use MATLAB Builder JA software to
automatically generate Java classes from algorithms written in the
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MATLAB programming language. You can run these classes outside the
MATLAB environment.
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Using Spreadsheet Link EX with Bioinformatic Data
If you have bioinformatic data in a Microsoft Excel spreadsheet, you can
use Spreadsheet Link EX software to connect Excel with the MATLAB
Workspace to exchange data and to use MATLAB and Bioinformatics Toolbox
computational and visualization functions.

Note The following example assumes you have Spreadsheet Link EX
software installed on your system.

The file used in the following example contains data from DeRisi, J.L., Iyer,
V.R., and Brown, P.O. (Oct. 24, 1997). Exploring the metabolic and genetic
control of gene expression on a genomic scale. Science 278(5338), 680–686.
PMID: 9381177. The data has been filtered using the steps described in the
Gene Expression Profile Analysis demo.

1 If you have not already done so, modify your system path to include the
MATLAB root directory as described in “Modifying Your System Path” in
the Spreadsheet Link EX documentation.

2 If you have not already done so, configure the software as described in
“Configuring the Spreadsheet Link EX Software” in the Spreadsheet Link
EX documentation.

3 Close MATLAB if you have it open.

4 Start Microsoft Excel. MATLAB and Spreadsheet Link EX software open
also.

5 From Excel, open the following file provided with the Bioinformatics
Toolbox software:

matlabroot\toolbox\bioinfo\biodemos\Filtered_Yeastdata.xls

Note The notation matlabroot is the MATLAB root directory, which is
the directory where the MATLAB software is installed on your system.
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Note When the Security Warning appears, click Enable Macros.

6 Note that cells J5, J6, J7, and J12 of the spreadsheet contain formulas
using Spreadsheet Link EX functions MLPutMatrix and MLEvalString.

Tip To view a cell’s formula, select the cell, then view the formula in the

formula bar at the top of the Excel window.

Cells J5, J6, and J7 each create a MATLAB variable from the data
in the spreadsheet, and cell J12 runs the Bioinformatics Toolbox
clustergram function using these three variables as input. For more
information on adding formulas using Spreadsheet Link EX functions, see
“Entering Functions into Worksheet Cells” in the Spreadsheet Link EX
documentation.
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Note that cell J17 contains a formula using a macro function Clustergram,
which was created in the Visual Basic Editor. Running this macro does the
same as the formulas in cells J5, J6, J7, and J12. To view the Clustergram
macro function, select Tools > Macro > Visual Basic Editor. For more
information on creating macros using Visual Basic Editor, see “Examples:
Using Spreadsheet Link EX Functions in Macros” in the Spreadsheet Link
EX documentation.
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7 Run the formula in cell J17 to analyze and visualize the data:

a Select cell J17.

b Press F2.

c Press Enter.

The macro function Clustergram runs creating three MATLAB variables
(data, Genes, and TimeSteps) and displaying a Clustergram window
containing dendrograms and a heat map of the data.

8 Edit the formulas in cells J5 and J6 to analyze a subset of the data. Do
this by editing the formulas’ cell ranges to include data for only the first
30 genes:

a Select cell J5, then press F2 to display the formula for editing. Change
H617 to H33, then press Enter.
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b Select cell J6, then press F2 to display the formula for editing. Change
A617 to A33, then press Enter.

9 Run the formulas in cells J5, J6, J7, and J12 to analyze and visualize
a subset of the data.

a Select cell J5, press F2, then press Enter.

b Select cell J6, press F2, then press Enter.

c Select cell J7, press F2, then press Enter.

d Select cell J12, press F2, then press Enter.
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10 Use the commands in the Spreadsheet Link EX toolbar to interact with
the data:

a Click-drag to select cells B5 through H7, click putmatrix in the toolbar,
type YAGenes for the variable name, then click OK. The variable
YAGenes is added to the MATLAB Workspace as a 3-by-7 matrix.

b Click evalstring in the toolbar, type plot(YAGenes ) for the command,
then click OK. A Figure window displays a plot of the data.

Note Make sure you use the ' (transpose) symbol when plotting the
data in this step. You need to transpose the data in YAGenes so that it
plots as three genes over seven time intervals.

c Select cell J20, then click getfigure in the toolbar. The figure is added
to the spreadsheet
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Creating get Functions

In this section...

“What Are get Functions?” on page 1-29

“Creating the getpubmed Function” on page 1-30

What Are get Functions?
Bioinformatics Toolbox includes several get functions that retrieve
information from various Web databases. Additionally, with some basic
MATLAB programming skills, you can create your own get function to
retrieve information from a specific Web database.

The following procedure illustrates how to create a function to retrieve
information from the NCBI PubMed database and read the information into
a MATLAB structure. The NCBI PubMed database contains biomedical
literature citations and abstracts.
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Creating the getpubmed Function
The following procedure shows you how to create a function named getpubmed
using the MATLAB Editor. This function will retrieve citation and abstract
information from PubMed literature searches and write the data to a
MATLAB structure.

Specifically, this function will take one or more search terms, submit them
to the PubMed database for a search, then return a MATLAB structure or
structure array, with each structure containing information for an article
found by the search. The returned information will include a PubMed
identifier, publication date, title, abstract, authors, and citation.

The function will also include property name/property value pairs that let
the user of the function limit the search by publication date and limit the
number of records returned.

1 From MATLAB, open the MATLAB Editor by selecting File > New >
M-File.

2 Define the getpubmed function, its input arguments, and return values by
typing:

function pmstruct = getpubmed(searchterm,varargin)
% GETPUBMED Search PubMed database & write results to MATLAB structure

3 Add code to do some basic error checking for the required input SEARCHTERM.

% Error checking for required input SEARCHTERM
if(nargin<1)

error('GETPUBMED:NotEnoughInputArguments',...
'SEARCHTERM is missing.');

end

4 Create variables for the two property name/property value pairs, and set
their default values.

% Set default settings for property name/value pairs,
% 'NUMBEROFRECORDS' and 'DATEOFPUBLICATION'
maxnum = 50; % NUMBEROFRECORDS default is 50
pubdate = ''; % DATEOFPUBLICATION default is an empty string
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5 Add code to parse the two property name/property value pairs if provided
as input.

% Parsing the property name/value pairs
num_argin = numel(varargin);
for n = 1:2:num_argin

arg = varargin{n};
switch lower(arg)

% If NUMBEROFRECORDS is passed, set MAXNUM
case 'numberofrecords'

maxnum = varargin{n+1};

% If DATEOFPUBLICATION is passed, set PUBDATE
case 'dateofpublication'

pubdate = varargin{n+1};

end
end

6 You access the PubMed database through a search URL, which submits
a search term and options, and then returns the search results in a
specified format. This search URL is comprised of a base URL and defined
parameters. Create a variable containing the base URL of the PubMed
database on the NCBI Web site.

% Create base URL for PubMed db site
baseSearchURL = 'http://www.ncbi.nlm.nih.gov/sites/entrez?cmd=search';

7 Create variables to contain five defined parameters that the getpubmed
function will use, namely, db (database), term (search term), report (report
type, such as MEDLINE®), format (format type, such as text), and dispmax
(maximum number of records to display).

% Set db parameter to pubmed
dbOpt = '&db=pubmed';

% Set term parameter to SEARCHTERM and PUBDATE
% (Default PUBDATE is '')
termOpt = ['&term=',searchterm,'+AND+',pubdate];
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% Set report parameter to medline
reportOpt = '&report=medline';

% Set format parameter to text
formatOpt = '&format=text';

% Set dispmax to MAXNUM
% (Default MAXNUM is 50)
maxOpt = ['&dispmax=',num2str(maxnum)];

8 Create a variable containing the search URL from the variables created
in the previous steps.

% Create search URL
searchURL = [baseSearchURL,dbOpt,termOpt,reportOpt,formatOpt,maxOpt];

9 Use the urlread function to submit the search URL, retrieve the search
results, and return the results (as text in the MEDLINE report type) in
medlineText, a character array.

medlineText = urlread(searchURL);

10 Use the MATLAB regexp function and regular expressions to parse and
extract the information in medlineText into hits, a cell array, where each
cell contains the MEDLINE-formatted text for one article. The first input
is the character array to search, the second input is a search expression,
which tells the regexp function to find all records that start with PMID-,
while the third input, 'match', tells the regexp function to return the
actual records, rather than the positions of the records.

hits = regexp(medlineText,'PMID-.*?(?=PMID|</pre>$)','match');

11 Instantiate the pmstruct structure returned by getpubmed to contain six
fields.

pmstruct = struct('PubMedID','','PublicationDate','','Title','',...
'Abstract','','Authors','','Citation','');

12 Use the MATLAB regexp function and regular expressions to loop through
each article in hits and extract the PubMed ID, publication date, title,
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abstract, authors, and citation. Place this information in the pmstruct
structure array.

for n = 1:numel(hits)

pmstruct(n).PubMedID = regexp(hits{n},'(?<=PMID- ).*?(?=\n)','match', 'once');

pmstruct(n).PublicationDate = regexp(hits{n},'(?<=DP - ).*?(?=\n)','match', 'once');

pmstruct(n).Title = regexp(hits{n},'(?<=TI - ).*?(?=PG -|AB -)','match', 'once');

pmstruct(n).Abstract = regexp(hits{n},'(?<=AB - ).*?(?=AD -)','match', 'once');

pmstruct(n).Authors = regexp(hits{n},'(?<=AU - ).*?(?=\n)','match');

pmstruct(n).Citation = regexp(hits{n},'(?<=SO - ).*?(?=\n)','match', 'once');

end

13 Select File > Save As.

When you are done, your M-file should look similar to the getpubmed.m
file included with the Bioinformatics Toolbox software. The sample
getpubmed.m file, including help, is located at:

matlabroot\toolbox\bioinfo\biodemos\getpubmed.m

Note The notation matlabroot is the MATLAB root directory, which is
the directory where the MATLAB software is installed on your system.
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Sequence Analysis

Sequence analysis is the process you use to find information about a nucleotide
or amino acid sequence using computational methods. Common tasks in
sequence analysis are identifying genes, determining the similarity of two
genes, determining the protein coded by a gene, and determining the function
of a gene by finding a similar gene in another organism with a known function.

• “Example: Sequence Statistics” on page 2-2

• “Example: Sequence Alignment” on page 2-18

• “Sequence Tool” on page 2-37

• “Multiple Sequence Alignment Viewer” on page 2-51



2 Sequence Analysis

Example: Sequence Statistics

In this section...

“Overview of Example” on page 2-2

“Determining Nucleotide Content” on page 2-2

“Reading Sequence Information” on page 2-4

“Determining Nucleotide Composition” on page 2-6

“Determining Codon Composition” on page 2-9

“Open Reading Frames” on page 2-12

“Amino Acid Conversion and Composition” on page 2-15

Overview of Example
After sequencing a piece of DNA, one of the first tasks is to investigate the
nucleotide content in the sequence. Starting with a DNA sequence, this
example uses sequence statistics functions to determine mono-, di-, and
trinucleotide content, and to locate open reading frames.

Determining Nucleotide Content
The following procedure illustrates how to use the MATLAB Help browser
to search the Web for information. In this example you are interested in
studying the human mitochondrial genome. While many genes that code for
mitochondrial proteins are found in the cell nucleus, the mitochondrial has
genes that code for proteins used to produce energy.

First research information about the human mitochondria and find the
nucleotide sequence for the genome. Next, look at the nucleotide content for
the entire sequence. And finally, determine open reading frames and extract
specific gene sequences.

1 Use the MATLAB Help browser to explore the Web. In the MATLAB
Command Window, type

web('http://www.ncbi.nlm.nih.gov/')
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A separate browser window opens with the home page for the NCBI Web
site.

2 Search the NCBI Web site for information. For example, to search for the
human mitochondrion genome, from the Search list, select Genome, and in
the for box, enter mitochondrion homo sapiens.

The NCBI Web search returns a list of links to relevant pages.

3 Select a result page. For example, click the link labeled NC_001807.

The MATLAB Help browser displays the NCBI page for the human
mitochondrial genome.
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Reading Sequence Information
The following procedure illustrates how to find a nucleotide sequence in
a public database and read the sequence information into the MATLAB
environment. Many public databases for nucleotide sequences are
accessible from the Web. The MATLAB Command Window provides an
integrated environment for bringing sequence information into the MATLAB
environment.

The consensus sequence for the human mitochondrial genome has the
GenBank accession number NC_001807. Since the whole GenBank entry is
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quite large and you might only be interested in the sequence, you can get
just the sequence information.

1 Get sequence information from a Web database. For example, to retrieve
sequence information for the human mitochondrial genome, in the
MATLAB Command Window, type

mitochondria = getgenbank('NC_001807','SequenceOnly',true);

The getgenbank function retrieves the nucleotide sequence from the
GenBank database and creates a character array.

mitochondria =
gatcacaggtctatcaccctattaaccactcacgggagctctccatgcat
ttggtattttcgtctggggggtgtgcacgcgatagcattgcgagacgctg
gagccggagcaccctatgtcgcagtatctgtctttgattcctgcctcatt
ctattatttatcgcacctacgttcaatattacaggcgaacatacctacta
aagt . . .

2 If you don’t have a Web connection, you can load the data from a MAT file
included with the Bioinformatics Toolbox software, using the command

load mitochondria

The load function loads the sequence mitochondria into the MATLAB
Workspace.

3 Get information about the sequence. Type

whos mitochondria

Information about the size of the sequence displays in the MATLAB
Command Window.

Name Size Bytes Class
mitochondria 1x16571 33142 char array

Grand total is 16571 elements using 33142 bytes
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Determining Nucleotide Composition
The following procedure illustrates how to determine the monomers and
dimers, and then visualize data in graphs and bar plots. Sections of a DNA
sequence with a high percent of A+T nucleotides usually indicate intergenic
parts of the sequence, while low A+T and higher G+C nucleotide percentages
indicate possible genes. Many times high CG dinucleotide content is located
before a gene.

After you read a sequence into the MATLAB environment, you can use
the sequence statistics functions to determine if your sequence has the
characteristics of a protein-coding region. This procedure uses the human
mitochondrial genome as an example. See “Reading Sequence Information”
on page 2-4.

1 Plot monomer densities and combined monomer densities in a graph. In
the MATLAB Command Window, type

ntdensity(mitochondria)

This graph shows that the genome is A+T rich.
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2 Count the nucleotides using the function basecount.basecount(mitochondria)

A list of nucleotide counts is shown for the 5’-3’ strand.ans =
A: 5113
C: 5192
G: 2180
T: 4086

3 Count the nucleotides in the reverse complement of a sequence using the
function seqrcomplement.

basecount(seqrcomplement(mitochondria))

As expected, the nucleotide counts on the reverse complement strand are
complementary to the 5’-3’ strand.

ans =
A: 4086
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C: 2180
G: 5192
T: 5113

4 Use the function basecount with the chart option to visualize the
nucleotide distribution.

basecount(mitochondria,'chart','pie');

A pie chart displays in the MATLAB Figure window.

5 Count the dimers in a sequence and display the information in a bar chart.

dimercount(mitochondria,'chart','bar')
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Determining Codon Composition
The following procedure illustrates how to look at codons for the six reading
frames. Trinucleotides (codon) code for an amino acid, and there are 64
possible codons in a nucleotide sequence. Knowing the percent of codons
in your sequence can be helpful when you are comparing with tables for
expected codon usage.

After you read a sequence into the MATLAB environment, you can analyze the
sequence for codon composition. This procedure uses the human mitochondria
genome as an example. See “Reading Sequence Information” on page 2-4.

1 Count codons in a nucleotide sequence. In the MATLAB Command
Window, type

codoncount(mitochondria)

The codon counts for the first reading frame displays.

AAA-172 AAC-157 AAG-67 AAT-123
ACA-153 ACC-163 ACG-42 ACT-130
AGA-58 AGC-90 AGG-50 AGT-43
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ATA-132 ATC-103 ATG-57 ATT-96
CAA-166 CAC-167 CAG-68 CAT-135
CCA-146 CCC-215 CCG-50 CCT-182
CGA-33 CGC-60 CGG-18 CGT-20
CTA-187 CTC-126 CTG-52 CTT-98
GAA-68 GAC-62 GAG-47 GAT-39
GCA-67 GCC-87 GCG-23 GCT-61
GGA-53 GGC-61 GGG-23 GGT-25
GTA-61 GTC-49 GTG-26 GTT-36
TAA-136 TAC-127 TAG-82 TAT-107
TCA-143 TCC-126 TCG-37 TCT-103
TGA-64 TGC-35 TGG-27 TGT-25
TTA-115 TTC-113 TTG-37 TTT-99

2 Count the codons in all six reading frames and plot the results in heat maps.

for frame = 1:3
figure('color',[1 1 1])
subplot(2,1,1);
codoncount(mitochondria,'frame',frame,'figure',true);
title(sprintf('Codons for frame %d',frame));
subplot(2,1,2);
codoncount(mitochondria,'reverse',true,...

'frame',frame,...
'figure',true);

title(sprintf('Codons for reverse frame %d',frame));
end

Heat maps display all 64 codons in the 6 reading frames.
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Open Reading Frames
The following procedure illustrates how to locate the open reading frames
using a specific genetic code. Determining the protein-coding sequence for a
eukaryotic gene can be a difficult task because introns (noncoding sections)
are mixed with exons. However, prokaryotic genes generally do not have
introns and mRNA sequences have the introns removed. Identifying the
start and stop codons for translation determines the protein-coding section,
or open reading frame (ORF), in a sequence. Once you know the ORF for a
gene or mRNA, you can translate a nucleotide sequence to its corresponding
amino acid sequence.

After you read a sequence into the MATLAB environment, you can analyze
the sequence for open reading frames. This procedure uses the human
mitochondria genome as an example. See “Reading Sequence Information”
on page 2-4.

1 Display open reading frames (ORFs) in a nucleotide sequence. In the
MATLAB Command Window, type:

seqshoworfs(mitochondria);
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If you compare this output to the genes shown on the NCBI page for
NC_001807, there are fewer genes than expected. This is because vertebrate
mitochondria use a genetic code slightly different from the standard genetic
code. For a list of genetic codes, see the “Genetic Code” table in the aa2nt
reference page in the Bioinformatics Toolbox Reference.

2 Display ORFs using the Vertebrate Mitochondrial code.

orfs= seqshoworfs(mitochondria,...
'GeneticCode','Vertebrate Mitochondrial',...
'alternativestart',true);

Notice that there are now two large ORFs on the first reading frame. One
starts at position 4471 and the other starts at 5905. These correspond to
the genes ND2 (NADH dehydrogenase subunit 2 [Homo sapiens] ) and
COX1 (cytochrome c oxidase subunit I) genes.

3 Find the corresponding stop codon. The start and stop positions for ORFs
have the same indices as the start positions in the fields Start and Stop.

ND2Start = 4471;
StartIndex = find(orfs(1).Start == ND2Start)
ND2Stop = orfs(1).Stop(StartIndex)

The stop position displays.

ND2Stop =
5512

4 Using the sequence indices for the start and stop of the gene, extract the
subsequence from the sequence.

ND2Seq = mitochondria(ND2Start:ND2Stop);
codoncount (ND2Seq)

The subsequence (protein-coding region) is stored in ND2Seq and displayed
on the screen.

attaatcccctggcccaacccgtcatctactctaccatctttgcaggcac
actcatcacagcgctaagctcgcactgattttttacctgagtaggcctag
aaataaacatgctagcttttattccagttctaaccaaaaaaataaaccct
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cgttccacagaagctgccatcaagtatttcctcacgcaagcaaccgcatc
cataatccttc . . .

5 Determine the codon distribution.

codoncount (ND2Seq)

The codon count shows a high amount of ACC, ATA, CTA, and ATC.

AAA-10 AAC-14 AAG-2 AAT-6
ACA-11 ACC-24 ACG-3 ACT-5
AGA-0 AGC-4 AGG-0 AGT-1
ATA-22 ATC-24 ATG-2 ATT-8
CAA-8 CAC-3 CAG-2 CAT-1
CCA-4 CCC-12 CCG-2 CCT-5
CGA-0 CGC-3 CGG-0 CGT-1
CTA-26 CTC-18 CTG-4 CTT-7
GAA-5 GAC-0 GAG-1 GAT-0
GCA-8 GCC-7 GCG-1 GCT-4
GGA-5 GGC-7 GGG-0 GGT-1
GTA-3 GTC-2 GTG-0 GTT-3
TAA-0 TAC-8 TAG-0 TAT-2
TCA-7 TCC-11 TCG-1 TCT-4
TGA-10 TGC-0 TGG-1 TGT-0
TTA-8 TTC-7 TTG-1 TTT-8

6 Look up the amino acids for codons ATA, CTA, ACC, and ATC.

aminolookup('code',nt2aa('ATA'))
aminolookup('code',nt2aa('CTA'))
aminolookup('code',nt2aa('ACC'))
aminolookup('code',nt2aa('ATC'))

The following displays:

Ile isoleucine
Leu leucine
Thr threonine
Ile isoleucine
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Amino Acid Conversion and Composition
The following procedure illustrates how to extract the protein-coding sequence
from a gene sequence and convert it to the amino acid sequence for the
protein. Determining the relative amino acid composition of a protein will
give you a characteristic profile for the protein. Often, this profile is enough
information to identify a protein. Using the amino acid composition, atomic
composition, and molecular weight, you can also search public databases
for similar proteins.

After you locate an open reading frame (ORF) in a gene, you can convert it to
an amino sequence and determine its amino acid composition. This procedure
uses the human mitochondria genome as an example. See “Open Reading
Frames” on page 2-12.

1 Convert a nucleotide sequence to an amino acid sequence. In this example,
only the protein-coding sequence between the start and stop codons is
converted.

ND2AASeq = nt2aa(ND2Seq,'geneticcode',...
'Vertebrate Mitochondrial');

The sequence is converted using the Vertebrate Mitochondrial genetic
code. Because the property AlternativeStartCodons is set to 'true' by
default, the first codon att is converted to M instead of I.

MNPLAQPVIYSTIFAGTLITALSSHWFFTWVGLEMNMLAFIPVLTKKMNP
RSTEAAIKYFLTQATASMILLMAILFNNMLSGQWTMTNTTNQYSSLMIMM
AMAMKLGMAPFHFWVPEVTQGTPLTSGLLLLTWQKLAPISIMYQISPSLN
VSLLLTLSILSIMAGSWGGLNQTQLRKILAYSSITHMGWMMAVLPYNPNM
TILNLTIYIILTTTAFLLLNLNSSTTTLLLSRTWNKLTWLTPLIPSTLLS
LGGLPPLTGFLPKWAIIEEFTKNNSLIIPTIMATITLLNLYFYLRLIYST
SITLLPMSNNVKMKWQFEHTKPTPFLPTLIALTTLLLPISPFMLMIL

2 Compare your conversion with the published conversion in the GenPept
database.

ND2protein = getgenpept('NP_536844','sequenceonly',true)

The getgenpept function retrieves the published conversion from the NCBI
database and reads it into the MATLAB Workspace.
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3 Count the amino acids in the protein sequence.

aacount(ND2AASeq, 'chart','bar')

A bar graph displays. Notice the high content for leucine, threonine and
isoleucine, and also notice the lack of cysteine and aspartic acid.

4 Determine the atomic composition and molecular weight of the protein.

atomiccomp(ND2AASeq)
molweight (ND2AASeq)

The following displays in the MATLAB Workspace:

ans =
C: 1818
H: 3574
N: 420
O: 817
S: 25

ans =
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3.8960e+004

If this sequence was unknown, you could use this information to identify
the protein by comparing it with the atomic composition of other proteins
in a database.
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Example: Sequence Alignment

In this section...

“Overview of Example” on page 2-18

“Finding a Model Organism to Study” on page 2-18

“Retrieving Sequence Information from a Public Database” on page 2-20

“Searching a Public Database for Related Genes” on page 2-23

“Locating Protein Coding Sequences” on page 2-25

“Comparing Amino Acid Sequences” on page 2-28

Overview of Example
Determining the similarity between two sequences is a common task in
computational biology. Starting with a nucleotide sequence for a human gene,
this example uses alignment algorithms to locate and verify a corresponding
gene in a model organism.

Finding a Model Organism to Study
The following procedure illustrates how to use the MATLAB Help browser
to search the Web for information. In this example, you are interested in
studying Tay-Sachs disease. Tay-Sachs is an autosomal recessive disease
caused by the absence of the enzyme beta-hexosaminidase A (Hex A). This
enzyme is responsible for the breakdown of gangliosides (GM2) in brain and
nerve cells.

First, research information about Tay-Sachs and the enzyme that is associated
with this disease, then find the nucleotide sequence for the human gene
that codes for the enzyme, and finally find a corresponding gene in another
organism to use as a model for study.

1 Use the MATLAB Help browser to explore the Web. In the MATLAB
Command window, type

web('http://www.ncbi.nlm.nih.gov/')
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The MATLAB Help browser opens with the home page for the NCBI Web
site.

2 Search the NCBI Web site for information. For example, to search for
Tay-Sachs, from the Search list, select NCBI Web Site, and in the for
box, enter Tay-Sachs.

The NCBI Web search returns a list of links to relevant pages.

3 Select a result page. For example, click the link labeled Tay-Sachs
Disease

A page in the genes and diseases section of the NCBI Web site opens. This
section provides a comprehensive introduction to medical genetics. In
particular, this page contains an introduction and pictorial representation
of the enzyme Hex A and its role in the metabolism of the lipid GM2
ganglioside.
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4 After completing your research, you have concluded the following:

The gene HEXA codes for the alpha subunit of the dimer enzyme
hexosaminidase A (Hex A), while the gene HEXB codes for the beta subunit
of the enzyme. A third gene, GM2A, codes for the activator protein GM2.
However, it is a mutation in the gene HEXA that causes Tay-Sachs.

Retrieving Sequence Information from a Public
Database
The following procedure illustrates how to find the nucleotide sequence for a
human gene in a public database and read the sequence information into the
MATLAB environment. Many public databases for nucleotide sequences (for
example, GenBank, EMBL-EBI) are accessible from the Web. The MATLAB
Command Window with the MATLAB Help browser provide an integrated
environment for searching the Web and bringing sequence information into
the MATLAB environment.

After you locate a sequence, you need to move the sequence data into the
MATLAB Workspace.
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1 Open the MATLAB Help browser to the NCBI Web site. In the MATLAB
Command Widow, type

web('http://www.ncbi.nlm.nih.gov/')

The MATLAB Help browser window opens with the NCBI home page.

2 Search for the gene you are interested in studying. For example, from the
Search list, select Nucleotide, and in the for box enter Tay-Sachs.

The search returns entries for the genes that code the alpha and beta
subunits of the enzyme hexosaminidase A (Hex A), and the gene that codes
the activator enzyme. The NCBI reference for the human gene HEXA has
accession number NM_000520.
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3 Get sequence data into the MATLAB environment. For example, to get
sequence information for the human gene HEXA, type

humanHEXA = getgenbank('NM_000520')

Note Blank spaces in GenBank accession numbers use the underline
character. Entering 'NM 00520' returns the wrong entry.

The human gene is loaded into the MATLAB Workspace as a structure.

humanHEXA =

LocusName: 'NM_000520'

LocusSequenceLength: '2255'

LocusNumberofStrands: ''

LocusTopology: 'linear'
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LocusMoleculeType: 'mRNA'

LocusGenBankDivision: 'PRI'

LocusModificationDate: '13-AUG-2006'

Definition: 'Homo sapiens hexosaminidase A (alpha polypeptide) (HEXA), mRNA.'

Accession: 'NM_000520'

Version: 'NM_000520.2'

GI: '13128865'

Project: []

Keywords: []

Segment: []

Source: 'Homo sapiens (human)'

SourceOrganism: [4x65 char]

Reference: {1x58 cell}

Comment: [15x67 char]

Features: [74x74 char]

CDS: [1x1 struct]

Sequence: [1x2255 char]

SearchURL: [1x108 char]

RetrieveURL: [1x97 char]

Searching a Public Database for Related Genes
The following procedure illustrates how to find the nucleotide sequence for
a mouse gene related to a human gene, and read the sequence information
into the MATLAB environment. The sequence and function of many genes
is conserved during the evolution of species through homologous genes.
Homologous genes are genes that have a common ancestor and similar
sequences. One goal of searching a public database is to find similar genes.
If you are able to locate a sequence in a database that is similar to your
unknown gene or protein, it is likely that the function and characteristics of
the known and unknown genes are the same.

After finding the nucleotide sequence for a human gene, you can do a BLAST
search or search in the genome of another organism for the corresponding
gene. This procedure uses the mouse genome as an example.

1 Open the MATLAB Help browser to the NCBI Web site. In the MATLAB
Command window, type

web('http://www.ncbi.nlm.nih.gov')
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2 Search the nucleotide database for the gene or protein you are interested in
studying. For example, from the Search list, select Nucleotide, and in the
for box enter hexosaminidase A.

The search returns entries for the mouse and human genomes. The NCBI
reference for the mouse gene HEXA has accession number AK080777.

3 Get sequence information for the mouse gene into the MATLAB
environment. Type

mouseHEXA = getgenbank('AK080777')
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The mouse gene sequence is loaded into the MATLAB Workspace as a
structure.

mouseHEXA =

LocusName: 'AK080777'
LocusSequenceLength: '1839'

LocusNumberofStrands: ''
LocusTopology: 'linear'

LocusMoleculeType: 'mRNA'
LocusGenBankDivision: 'HTC'

LocusModificationDate: '02-SEP-2005'
Definition: [1x150 char]
Accession: 'AK080777'

Version: 'AK080777.1'
GI: '26348756'

Project: []
Keywords: 'HTC; CAP trapper.'
Segment: []
Source: 'Mus musculus (house mouse)'

SourceOrganism: [4x65 char]
Reference: {1x8 cell}

Comment: [8x66 char]
Features: [33x74 char]

CDS: [1x1 struct]
Sequence: [1x1839 char]

SearchURL: [1x107 char]
RetrieveURL: [1x97 char]

Locating Protein Coding Sequences
The following procedure illustrates how to convert a sequence from nucleotides
to amino acids and identify the open reading frames. A nucleotide sequence
includes regulatory sequences before and after the protein coding section. By
analyzing this sequence, you can determine the nucleotides that code for
the amino acids in the final protein.

After you have a list of genes you are interested in studying, you can
determine the protein coding sequences. This procedure uses the human gene
HEXA and mouse gene HEXA as an example.
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1 If you did not retrieve gene data from the Web, you can load example data
from a MAT-file included with the Bioinformatics Toolbox software. In the
MATLAB Command window, type

load hexosaminidase

The structures humanHEXA and mouseHEXA load into the MATLAB
Workspace.

2 Look for open reading frames in the human gene. For example, for the
human gene HEXA, type

humanORFs=seqshoworfs(humanHEXA.Sequence)

seqshoworfs creates the output structure humanORFs. This structure gives
the position of the start and stop codons for all open reading frames (ORFs)
on each reading frame.

humanORFs =

1x3 struct array with fields:
Start
Stop

The Help browser opens with a listing for the three reading frames with
the ORFs colored blue, red, and green. Notice that the longest ORF is
on the third reading frame.
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3 Locate open reading frames (ORFs) on the mouse gene. Type:

mouseORFs = seqshoworfs(mouseHEXA.Sequence)

seqshoworfs creates the structure mouseORFS.

mouseORFs =

1x3 struct array with fields:
Start
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Stop

The mouse gene shows the longest ORF on the first reading frame.

Comparing Amino Acid Sequences
The following procedure illustrates how to use global and local alignment
functions to compare two amino acid sequences. You could use alignment
functions to look for similarities between two nucleotide sequences, but
alignment functions return more biologically meaningful results when you
are using amino acid sequences.

After you have located the open reading frames on your nucleotide sequences,
you can convert the protein coding sections of the nucleotide sequences to
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their corresponding amino acid sequences, and then you can compare them
for similarities.

1 Using the identified open reading frames, convert the DNA sequence to the
amino acid sequences. Type

mouseProtein = nt2aa(mouseHEXA.Sequence)

Remember that the human HEXA gene was on the third reading frame, so
you need to indicate which frame to use.

humanProtein = nt2aa(humanHEXA.Sequence,'frame',3)

2 Draw a dot plot comparing the human and mouse amino acid sequences.
Type

seqdotplot(mouseProtein,humanProtein,4,3)
ylabel('Mouse hexosaminidase A (alpha subunit)')
xlabel('Human hexosaminidase A (alpha subunit)')

Dot plots are one of the easiest ways to look for similarity between
sequences. The diagonal line shown below indicates that there may be a
good alignment between the two sequences.

2-29



2 Sequence Analysis

3 Globally align the two amino acid sequences, using the Needleman-Wunsch
algorithm. Type

[GlobalScore, GlobalAlignment] = nwalign(humanProtein,...
mouseProtein)

showalignment(GlobalAlignment)

showalignment displays the global alignment of the two sequences in
the Help browser. Notice that the calculated identity between the two
sequences is 64.5 %.
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The alignment is very good for the first 550 nucleotides, after which the
two sequences appear to be unrelated. Notice that there is a stop (*) in the
sequence at this point. If you shorten the sequence to include only the
amino acids that are in the protein (after the first methionine and before
the first stop) you might get a better alignment.

4 Trim the sequence from the first start amino acid (usually M) to the first
stop (first *) and then try alignment again. Find the indices for the stops
in the sequences.

humanStops = find(humanProtein == '*')

humanStops =
538 550 652 661 669

mouseStops = find(mouseProtein =='*')

mouseStops =

539 557 574 606

Looking at the amino acid sequence for humanProtein, the first M is at
position 9, while the first M for the mouse protein is at 11.

5 Truncate the sequence to include only amino acids in the protein and the
stop.

humanProteinORF = humanProtein(9:humanStops(1));

humanProteinORF =
MTSSRLWFSLLLAAAFAGRATALWPWPQNFQTSDQRYVLYPNNFQFQYDV
SSAAQPGCSVLDEAFQRYRDLLFGSGSWPRPYLTGKRHTLEKNVLVVSVV
TPGCNQLPTLESVENYTLTINDDQCLLLSETVWGALRGLETFSQLVWKSA
EGTFFINKTEIEDFPRFPHRGLLLDTSRHYLPLSSILDTLDVMAYNKLNV
FHWHLVDDPSFPYESFTFPELMRKGSYNPVTHIYTAQDVKEVIEYARLRG
IRVLAEFDTPGHTLSWGPGIPGLLTPCYSGSEPSGTFGPVNPSLNNTYEF
MSTFFLEVSSVFPDFYLHLGGDEVDFTCWKSNPEIQDFMRKKGFGEDFKQ
LESFYIQTLLDIVSSYGKGYVVWQEVFDNKVKIQPDTIIQVWREDIPVNY
MKELELVTKAGFRALLSAPWYLNRISYGPDWKDFYVVEPLAFEGTPEQKA
LVIGGEACMWGEYVDNTNLVPRLWPRAGAVAERLWSNKLTSDLTFAYERL
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SHFRCELLRRGVQAQPLNVGFCEQEFEQT*

mouseProteinORF = mouseProtein(11:mouseStops(1))

mouseProteinORF =
MAGCRLWVSLLLAAALACLATALWPWPQYIQTYHRRYTLYPNNFQFRYHV
SSAAQAGCVVLDEAFRRYRNLLFGSGSWPRPSFSNKQQTLGKNILVVSVV
TAECNEFPNLESVENYTLTINDDQCLLASETVWGALRGLETFSQLVWKSA
EGTFFINKTKIKDFPRFPHRGVLLDTSRHYLPLSSILDTLDVMAYNKFNV
FHWHLVDDSSFPYESFTFPELTRKGSFNPVTHIYTAQDVKEVIEYARLRG
IRVLAEFDTPGHTLSWGPGAPGLLTPCYSGSHLSGTFGPVNPSLNSTYDF
MSTLFLEISSVFPDFYLHLGGDEVDFTCWKSNPNIQAFMKKKGFTDFKQL
ESFYIQTLLDIVSDYDKGYVVWQEVFDNKVKVRPDTIIQVWREEMPVEYM
LEMQDITRAGFRALLSAPWYLNRVKYGPDWKDMYKVEPLAFHGTPEQKAL
VIGGEACMWGEYVDSTNLVPRLWPRAGAVAERLWSSNLTTNIDFAFKRLS
HFRCELVRRGIQAQPISVGCCEQEFEQT*

6 Globally align the trimmed amino acid sequences. Type

[Score, Alignment] = nwalign(humanProteinORF,...
mouseProteinORF);

showalignment(Alignment)

showalignment displays the results for the second global alignment. Notice
that the percent identity for the untrimmed sequences is 54% and with
trimmed sequences 83.3 percent.
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7 Another way to truncate an amino acid sequence to only those amino acids
in the protein is to first truncate the nucleotide sequence with indices from
the function seqshoworfs. Remember that the ORF for the human HEXA
gene was on the third reading frame, and the ORF for the mouse HEXA
was on the first reading frame.
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humanORFs = seqshoworfs(humanHEXA.Sequence);
mouseORFs = seqshoworfs(humanHEXA.Sequence);

humanPORF = nt2aa(humanHEXA.Sequence(humanORFs(3).Start(1):...
humanORFs(3).Stop(1)))

mousePORF = nt2aa(mouseHEXA.Sequence(mouseORFs(1).Start(1):...
mouseORFs(1).Stop(1)))

[Scale, Alignment] = nwalign(humanPORF, mousePORF)

Show the alignment in the Help browser.

showalignment(Alignment)

The result from first truncating a nucleotide sequence before converting
to an amino acid sequence is the same as the result from truncating the
amino acid sequence after conversion. See the result in step 6.

An alternative method to working with subsequences is to use a local
alignment function with the nontruncated sequences.

8 Locally align the two amino acid sequences using a Smith-Waterman
algorithm. Type

[LocalScore, LocalAlignment] = swalign(humanProtein,...
mouseProtein)

LocalScore =
1057

LocalAlignment
RGDQR-AMTSSRLWFSLLLAAAFAGRATALWPWPQNFQTSDQRYV . . .
|| | ||:: ||| |||||||:| ||||||||| :|| :||: . . .
RGAGRWAMAGCRLWVSLLLAAALACLATALWPWPQYIQTYHRRYT . . .

swalign displays the local alignment of two sequences in the Help browser.

9 Show the alignment in color.

showalignment(LocalAlignment)
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Sequence Tool

In this section...

“Overview of the Sequence Tool” on page 2-37

“Importing a Sequence” on page 2-37

“Viewing Nucleotide Sequence Information” on page 2-39

“Searching for Words” on page 2-41

“Exploring Open Reading Frames” on page 2-43

“Viewing Amino Acid Sequence Statistics” on page 2-46

“Closing the Sequence Tool” on page 2-50

“References” on page 2-50

Overview of the Sequence Tool
The Sequence Tool window integrates many of the sequence functions in the
toolbox. Instead of entering commands in the MATLAB Command Window,
you can select and enter options.

Importing a Sequence
The first step when analyzing a nucleotide or amino acid sequence is to import
sequence information into the MATLAB environment. The Sequence Tool can
connect to Web databases such as NCBI and EMBL and read information into
the MATLAB environment.

The following procedure illustrates how to retrieve sequence information from
the NCBI database on the Web. This example uses the GenBank accession
number NM_000520, which is the human gene HEXA that is associated with
Tay-Sachs disease.

1 In the MATLAB Command Window, type

seqtool

The Sequence Tool window opens without a sequence loaded. Notice that
the panes to the right and bottom are blank.
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2 To retrieve a sequence from the NCBI database, select File > Download
Sequence from > NCBI.

The Download Sequence From NCBI dialog box opens.

3 In the Enter Sequence box, type an accession number for an NCBI
database entry, for example, NM_000520. Select the Nucleotide option
button, and then click OK.

The MATLAB software accesses the NCBI database on the Web, loads
nucleotide sequence information for the accession number you entered,
and calculates some basic statistics.
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Viewing Nucleotide Sequence Information
After you import a sequence into the Sequence Tool window, you can read
information stored with the sequence, or you can view graphic representations
for ORFs and CDSs.

1 In the left pane tree, click Comments. The right pane displays general
information about the sequence.

2 Now click Features. The right pane displays NCBI feature information,
including index numbers for a gene and any CDS sequences.

3 Click ORF to show the search results for ORFs in the six reading frames.

2-39



2 Sequence Analysis

4 Click Annotated CDS to show the protein coding part of a nucleotide
sequence.
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Searching for Words
The following procedure illustrates how to search for characteristic words and
sequence patterns. You will search for sequence patterns like the TATAA box
and patterns for specific restriction enzymes.

1 Select Sequence > Find Word.

2 In the Find Word dialog box, type a sequence word or pattern, for example,
atg, then click Find.
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The Sequence Tool window searches and displays the location of the
selected word.

3 Clear the display by clicking the Clear Word Selection button on
the toolbar.
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Exploring Open Reading Frames
The following procedure illustrates how to identify the protein coding part of a
nucleotide sequence and copy it into a new view. Identifying coding sections
of a nucleotide sequence is a common bioinformatics task. After locating the
coding part of a sequence, you can copy it to a new view, translate it to an
amino acid sequence, and continue with your analysis.

1 In the left pane, click ORF.

The Sequence Tool window displays the ORFs for the six reading frames in
the lower-right pane. Hover the cursor over a frame to display information
about it.

2 Click the longest ORF on reading frame 2.

The ORF is highlighted to indicate the part of the sequence that is selected.

3 Right-click the selected ORF and then select Export to Workspace. In
the Export to MATLAB Workspace dialog box, type a variable name, for
example, NM_000520_ORF_2, then click Export.
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The NM_000520_ORF_2 variable is added to the MATLAB Workspace.

4 Select File > Import from Workspace. Type the name of a variable
with an exported ORF, for example, NM_000520_ORF_2, and then click
Import.

The Sequence Tool window adds a tab at the bottom for the new sequence
while leaving the original sequence open.
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5 In the left pane, click Full Translation. Select Display > Amino Acid
Residue Display > One Letter Code.

The Sequence Tool window displays the amino acid sequence below the
nucleotide sequence.
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Viewing Amino Acid Sequence Statistics
The following procedure illustrates how to view an amino acid sequence for
an ORF located in a nucleotide sequence. You can import your own amino
acid sequence, or you can get a protein sequence from the GenBank database.
This example uses the GenBank accession number NP_000511.1, which is the
alpha subunit for a human enzyme associated with Tay-Sachs disease.

1 Select File > Download Sequence from > NCBI.

The Download Sequence From NCBI dialog box opens.
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2 In the Enter Sequence box, type an accession number for an NCBI
database entry, for example, NP_000511.1. Select the Protein option
button, and then click OK.

The MATLAB software accesses the NCBI database on the Web and loads
amino acid sequence information for the accession number you entered.
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3 Select Display > Amino Acid Color Scheme, and then select Charge,
Function, Hydrophobicity, Structure, or Taylor. For example, select
Function.

The display colors change to highlight charge information about the amino
acid residues. Color legends for the amino acid color schemes are in the
following table.
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Amino Acid Color
Scheme

Color Legend

Charge • Acidic — Red

• Basic — Light Blue

• Neutral — Black
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Amino Acid Color
Scheme

Color Legend

Function • Acidic — Red

• Basic — Light Blue

• Hydropobic, nonpolar — Black

• Polar, uncharged — Green

Hydrophobicity • Hydrophilic — Light Blue

• Hydrophobic — Black

Structure • Ambivalent — Dark Green

• External — Light Blue

• Internal — Orange

Taylor Each amino acid is assigned its own color,
based on the colors proposed by W.R. Taylor.

Closing the Sequence Tool
You can close the Sequence Tool window from the MATLAB command line by
using the following syntax:

seqtool('close')

References

[1] Taylor, W.R. (1997). Reisdual colours: a proposal for aminochromography.
Protein Engineering 10, 7, 743–746.
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Multiple Sequence Alignment Viewer

In this section...

“Overview of the Multiple Sequence Alignment Viewer” on page 2-51

“Loading Sequence Data and Viewing the Phylogenetic Tree” on page 2-51

“Selecting a Subset of Data from the Phylogenetic Tree” on page 2-52

“Aligning Multiple Sequences” on page 2-53

“Adjusting Multiple Sequence Alignments Manually” on page 2-54

“Closing the Multiple Sequence Alignment Viewer” on page 2-57

Overview of the Multiple Sequence Alignment Viewer
The Multiple Sequence Alignment Viewer is a graphical user interface (GUI)
that integrates many sequence and multiple alignment functions in the
toolbox. Instead of entering commands in the MATLAB Command Window,
you can use this interface to visually inspect a multiple alignment and make
manual adjustments.

Loading Sequence Data and Viewing the
Phylogenetic Tree
Load unaligned sequence data into the MATLAB environment and view it
in a phylogenetic tree.

1 Load sequence data.

load primatesdemodata

2 Create a phylogenetic tree.

tree = seqlinkage(seqpdist(primates),'single', primates);

3 View the phylogenetic tree.

view(tree)
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The MATLAB software creates a phytree object in the workspace and loads
the sequence data into the Phylogenetic Tree Tool.

Selecting a Subset of Data from the Phylogenetic Tree
Select the human and chimp branches.

1 From the toolbar, click the Prune icon.

2 Click the branches to prune (remove) from the tree. For this example, click
the branch nodes for gorillas, orangutans, and Neanderthals.
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3 Export the selected branches to a second tree. Select File > Export to
Workspace, and then select Only Displayed.

4 In the Export to dialog box, enter the name of a variable. For example,
enter tree2, and then click OK.

5 Extract sequences from the tree object.

primates2 = primates(seqmatch(get(tree2, 'Leafnames'),{primates.Header}));

Aligning Multiple Sequences
After selecting a set of related sequences, you can multiply align them and
view the results.

1 Align multiple sequences.

ma = multialign(primates2);

2 Load aligned sequences in the Multiple Alignment Viewer.

multialignviewer(ma);
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The aligned sequences appear in the Multiple Sequence Alignment Viewer.

Adjusting Multiple Sequence Alignments Manually
Algorithms for aligning multiple sequences do not always produce an optimal
result. By visually inspecting the alignment, you can identify areas that could
use a manual adjustment to improve the alignment.

1 Identify an area where you could improve the alignment.

2-54



Multiple Sequence Alignment Viewer

2 Click a letter to select it, and then move the cursor over the red direction
bar. The cursor changes to a hand.

3 Click and drag the sequence to the right to insert a gap. If there is a gap to
the left, you can also move the sequence to the left and eliminate the gap.
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Alternately, to insert a gap, select a character, and then click the Insert
Gap icon on the toolbar or press the spacebar.

Note You cannot delete or add letters to a sequence, but you can add or
delete gaps. If all of the sequences at one alignment position have gaps,
you can delete that column of gaps.

4 Continue adding gaps and moving sequences to improve the alignment.
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Closing the Multiple Sequence Alignment Viewer
You can close the Multiple Sequence Alignment Viewer window from the
MATLAB command line by using the following syntax:

multialignviewer('close')
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3 Microarray Analysis

Working with ExpressionSet Objects

In this section...

“Overview of ExpressionSet Objects” on page 3-2

“Constructing ExpressionSet Objects” on page 3-4

“Using Properties and Methods of an ExpressionSet Object” on page 3-5

Overview of ExpressionSet Objects
An ExpressionSet object contains information from a microarray gene
expression experiment. The information from such an experiment is typically
subdivided into four categories:

• Measured expression values

• Sample metadata

• Microarray feature metadata

• Descriptions of experiment methods and conditions

An ExpressionSet object typically contains the previous information in:

• One ExptData object containing expression values from a microarray
experiment in one or more DataMatrix objects

• One MetaData object containing sample metadata in two dataset arrays

• One MetaData object containing feature metadata in two dataset arrays

• One MIAME object containing experiment descriptions

The following graphic illustrates a typical ExpressionSet object and its
component objects.
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Each element (DataMatrix object) in the ExpressionSet object has an element
name. Also, there is always one DataMatrix object whose element name is
Expressions.

An ExpressionSet object lets you store, manage, and subset the data from a
microarray gene expression experiment. An ExpressionSet object includes
properties and methods that let you access, retrieve, and change data,
metadata, and other information about the microarray experiment. These
properties and methods are useful to view and analyze the data. For a list of
the properties and methods, see ExpressionSet class.

Constructing ExpressionSet Objects
1 Import the bioma package so that the ExpresssionSet constructor function
is available.

import bioma.*

2 Construct an ExpressionSet object from EDObj, an ExptData object, MDObj2,
a MetaData object containing sample variable information, and MIAMEObj,
a MIAME object.

ESObj = ExpressionSet(EDObj, 'SData', MDObj2, 'EInfo', MIAMEObj1);

3 Display information about the ExpressionSet object, ESObj.

ESObj

ExpressionSet
Experiment Data: 500 features, 26 samples

Element names: Expressions
Sample Data:

Sample names: A, B, ...,Z (26 total)
Sample variable names and meta information:

Gender: Gender of the mouse in study
Age: The number of weeks since mouse birth
Type: Genetic characters
Strain: The mouse strain
Source: The tissue source for RNA collection

Feature Data: none
Experiment Information: use 'exptInfo(obj)'
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For complete information on constructing ExpressionSet objects, see
ExpressionSet class.

Using Properties and Methods of an ExpressionSet
Object
To access properties of an ExpressionSet object, use the following syntax:

objectname.propertyname

For example, to determine the number of samples in an ExpressionSet object:

ESObj.NSamples

ans =

26

Note For a list and description of all properties of an ExpressionSet object,
see ExpressionSet class.

To use methods of an ExpressionSet object, use either of the following
syntaxes:

objectname.methodname

or

methodname(objectname)

For example, to retrieve the sample variable names from an ExpressionSet
object:

ESObj.sampleVarNames

ans =

'Gender' 'Age' 'Type' 'Strain' 'Source'
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To retrieve the experiment information contained in an ExpressionSet object:

exptInfo(ESObj)

ans =

Experiment description

Author name: Mika,,Silvennoinen

Riikka,,Kivelˆ⁄

Maarit,,Lehti

Anna-Maria,,Touvras

Jyrki,,Komulainen

Veikko,,Vihko

Heikki,,Kainulainen

Laboratory: LIKES - Research Center

Contact information: Mika,,Silvennoinen

URL:

PubMedIDs: 17003243

Abstract: A 90 word abstract is available Use the Abstract property.

Experiment Design: A 234 word summary is available Use the ExptDesign property.

Other notes:

[1x80 char]

Note For a complete list of methods of an ExpressionSet object, see
ExpressionSet class.
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Working with ExptData Objects

In this section...

“Overview of ExptData Objects” on page 3-7

“Constructing ExptData Objects” on page 3-7

“Using Properties and Methods of an ExptData Object” on page 3-8

“References” on page 3-10

Overview of ExptData Objects
An ExptData object contains data values from a microarray experiment. It
stores the data values in one or more DataMatrix objects, each having the
same row names (feature names) and column names (sample names). Each
element (DataMatrix object) in the ExptData object has an element name.

The following illustrates a small DataMatrix object containing expression
values from three samples (columns) and seven features (rows):

A B C
100001_at 2.26 20.14 31.66
100002_at 158.86 236.25 206.27
100003_at 68.11 105.45 82.92
100004_at 74.32 96.68 84.87
100005_at 75.05 53.17 57.94
100006_at 80.36 42.89 77.21
100007_at 216.64 191.32 219.48

An ExptData object lets you store, manage, and subset the data values from a
microarray experiment. An ExptData object includes properties and methods
that let you access, retrieve, and change data values from a microarray
experiment. These properties and methods are useful to view and analyze the
data. For a list of the properties and methods, see ExptData class.

Constructing ExptData Objects
The mouseExprsData.txt file used in this example contains data from
Hovatta et al., 2005.
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1 Import the bioma.data package so that the DataMatrix and ExptData
constructor functions are available.

import bioma.data.*

2 Use the DataMatrix constructor function to create a DataMatrix object
from the gene expression data in the mouseExprsData.txt file. This
file contains a table of expression values and metadata (sample and
feature names) from a microarray experiment done using the Affymetrix
MGU74Av2 GeneChip array. There are 26 sample names (A through Z),
and 500 feature names (probe set names).

dmObj = DataMatrix('File', 'mouseExprsData.txt');

3 Use the ExptData constructor function to create an ExptData object from
the DataMatrix object.

EDObj = ExptData(dmObj);

4 Display information about the ExptData object, EDObj.

EDObj

Experiment Data:
500 features, 26 samples
1 elements
Element names: Elmt1

Note For complete information on constructing ExptData objects, see
ExptData class.

Using Properties and Methods of an ExptData Object
To access properties of an ExptData object, use the following syntax:

objectname.propertyname

For example, to determine the number of elements (DataMatrix objects) in
an ExptData object:
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EDObj.NElements

ans =

1

Note For a list and description of all properties of an ExptData object, see
ExptData class.

To use methods of an ExptData object, use either of the following syntaxes:

objectname.methodname

or

methodname(objectname)

For example, to retrieve the sample names from an ExptData object:

EDObj.sampleNames

Columns 1 through 9

'A' 'B' 'C' 'D' 'E' 'F' 'G' 'H' 'I' ...

To return the size of an ExptData object:

size(EDObj)

ans =

500 26

Note For a complete list of methods of an ExptData object, see ExptData
class.
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References

[1] Hovatta, I., Tennant, R S., Helton, R., et al. (2005). Glyoxalase 1 and
glutathione reductase 1 regulate anxiety in mice. Nature 438, 662–666.
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Working with MetaData Objects

In this section...

“Overview of MetaData Objects” on page 3-11

“Constructing MetaData Objects” on page 3-12

“Using Properties and Methods of a MetaData Object” on page 3-15

Overview of MetaData Objects
A MetaData object can contain either sample or feature metadata from a
microarray gene expression experiment. The metadata consists of variable
names, for example, related to either samples or microarray features, along
with descriptions and values for the variables.

A MetaData object stores the metadata in two dataset arrays:

• Values dataset array— A dataset array containing the measured value
of each variable per sample or feature. In this dataset array, the columns
correspond to variables and rows correspond to either samples or features.
The number and names of the columns in this dataset array must match
the number and names of the rows in the Descriptions dataset array. If
this dataset array contains sample metadata, then the number and names
of the rows (samples) must match the number and names of the columns
in the DataMatrix objects in the same ExpressionSet object. If this
dataset array contains feature metadata, then the number and names of
the rows (features) must match the number and names of the rows in the
DataMatrix objects in the same ExpressionSet object.

• Descriptions dataset array — A dataset array containing a list of the
variable names and their descriptions. In this dataset array, each row
corresponds to a variable. The row names are the variable names, and
a column, named VariableDescription, contains a description of the
variable. The number and names of the rows in the Descriptions dataset
array must match the number and names of the columns in the Values
dataset array.

The following illustrates a dataset array containing the measured value of
each variable per sample or feature:

3-11



3 Microarray Analysis

Gender Age Type Strain Source
A 'Male' 8 'Wild type' '129S6/SvEvTac' 'amygdala'
B 'Male' 8 'Wild type' '129S6/SvEvTac' 'amygdala'
C 'Male' 8 'Wild type' '129S6/SvEvTac' 'amygdala'
D 'Male' 8 'Wild type' 'A/J ' 'amygdala'
E 'Male' 8 'Wild type' 'A/J ' 'amygdala'
F 'Male' 8 'Wild type' 'C57BL/6J ' 'amygdala'

The following illustrates a dataset array containing a list of the variable
names and their descriptions:

VariableDescription
id 'Sample identifier'
Gender 'Gender of the mouse in study'
Age 'The number of weeks since mouse birth'
Type 'Genetic characters'
Strain 'The mouse strain'
Source 'The tissue source for RNA collection'

A MetaData object lets you store, manage, and subset the metadata from a
microarray experiment. A MetaData object includes properties and methods
that let you access, retrieve, and change metadata from a microarray
experiment. These properties and methods are useful to view and analyze the
metadata. For a list of the properties and methods, see MetaData class

Constructing MetaData Objects

Constructing a MetaData Object from Two dataset Arrays

1 Import the bioma.data package so that the MetaData constructor function
is available.

import bioma.data.*

2 Load some sample data, which includes Fisher’s iris data of 5 measurements
on a sample of 150 irises.

load fisheriris
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3 Create a dataset array from some of Fisher’s iris data. The dataset
array will contain 750 measured values, one for each of 150 samples (iris
replicates) at five variables (species, SL, SW, PL, PW). In this dataset array,
the rows correspond to samples, and the columns correspond to variables.

irisValues = dataset({nominal(species),'species'}, ...
{meas, 'SL', 'SW', 'PL', 'PW'});

4 Create another dataset array containing a list of the variable names
and their descriptions. This dataset array will contain five rows, each
corresponding to the five variables: species, SL, SW, PL, and PW. The
first column will contain the variable name. The second column will have
a column header of VariableDescription and contain a description of
the variable.

% Create 5-by-1 cell array of description text for the variables
varDesc = {'Iris species', 'Sepal Length', 'Sepal Width', ...

'Petal Length', 'Petal Width'}';
% Create the dataset array from the variable descriptions
irisVarDesc = dataset(varDesc, ...

'ObsNames', {'species','SL','SW','PL','PW'}, ...
'VarNames', {'VariableDescription'})

irisVarDesc =

VariableDescription
species 'Iris species'
SL 'Sepal Length'
SW 'Sepal Width'
PL 'Petal Length'
PW 'Petal Width'

5 Create a MetaData object from the two dataset arrays.

MDObj1 = MetaData(irisValues, irisVarDesc);

Constructing a MetaData Object from a Text File

1 Import the bioma.datapackage so that the MetaData constructor function
is available.
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import bioma.data.*

2 View the mouseSampleData.txt file included with the Bioinformatics
Toolbox software.

Note that this text file contains two tables. One table contains 130
measured values, one for each of 26 samples (A through Z) at five variables
(Gender, Age, Type, Strain, and Source). In this table, the rows correspond
to samples, and the columns correspond to variables. The second table has
lines prefaced by the # symbol. It contains five rows, each corresponding to
the five variables: Gender, Age, Type, Strain, and Source. The first column
contains the variable name. The second column has a column header of
VariableDescription and contains a description of the variable.

# id: Sample identifier
# Gender: Gender of the mouse in study
# Age: The number of weeks since mouse birth
# Type: Genetic characters
# Strain: The mouse strain
# Source: The tissue source for RNA collection
ID Gender Age Type Strain Source
A Male 8 Wild type 129S6/SvEvTac amygdala
B Male 8 Wild type 129S6/SvEvTac amygdala
C Male 8 Wild type 129S6/SvEvTac amygdala
D Male 8 Wild type A/J amygdala
E Male 8 Wild type A/J amygdala
F Male 8 Wild type C57BL/6J amygdala
G Male 8 Wild type C57BL/6J amygdala
H Male 8 Wild type 129S6/SvEvTac cingulate cortex
I Male 8 Wild type 129S6/SvEvTac cingulate cortex
J Male 8 Wild type A/J cingulate cortex
K Male 8 Wild type A/J cingulate cortex
L Male 8 Wild type A/J cingulate cortex
M Male 8 Wild type C57BL/6J cingulate cortex
N Male 8 Wild type C57BL/6J cingulate cortex
O Male 8 Wild type 129S6/SvEvTac hippocampus
P Male 8 Wild type 129S6/SvEvTac hippocampus
Q Male 8 Wild type A/J hippocampus
R Male 8 Wild type A/J hippocampus
S Male 8 Wild type C57BL/6J hippocampus
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T Male 8 Wild type C57BL/6J4 hippocampus
U Male 8 Wild type 129S6/SvEvTac hypothalamus
V Male 8 Wild type 129S6/SvEvTac hypothalamus
W Male 8 Wild type A/J hypothalamus
X Male 8 Wild type A/J hypothalamus
Y Male 8 Wild type C57BL/6J hypothalamus
Z Male 8 Wild type C57BL/6J hypothalamus

3 Create a MetaData object from the metadata in the mouseSampleData.txt
file.

MDObj2 = MetaData('File', 'mouseSampleData.txt', 'VarDescChar', '#')

Sample Names:

A, B, ...,Z (26 total)

Variable Names and Meta Information:

VariableDescription

Gender ' Gender of the mouse in study'

Age ' The number of weeks since mouse birth'

Type ' Genetic characters'

Strain ' The mouse strain'

Source ' The tissue source for RNA collection'

For complete information on constructing MetaData objects, see MetaData
class.

Using Properties and Methods of a MetaData Object
To access properties of a MetaData object, use the following syntax:

objectname.propertyname

For example, to determine the number of variables in a MetaData object:

MDObj2.NVariables

ans =

5
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Note For a list and description of all properties of a MetaData object, see
MetaData class.

To use methods of a MetaData object, use either of the following syntaxes:

objectname.methodname

or

methodname(objectname)

For example, to access the dataset array in a MetaData object that contains
the variable values:

MDObj2.variableValues;

To access the dataset array of a MetaData object that contains the variable
descriptions:

variableDesc(MDObj2)

ans =

VariableDescription
Gender ' Gender of the mouse in study'
Age ' The number of weeks since mouse birth'
Type ' Genetic characters'
Strain ' The mouse strain'
Source ' The tissue source for RNA collection'

Note For a complete list of methods of a MetaData object, see MetaData
class.
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Working with MIAME Objects

In this section...

“Overview of MIAME Objects” on page 3-17

“Constructing MIAME Objects” on page 3-17

“Using Properties and Methods of a MIAME Object” on page 3-19

Overview of MIAME Objects
A MIAME object contains information about experimental methods and
conditions from a microarray gene expression experiment. It loosely follows
the Minimum Information About a Microarray Experiment (MIAME)
specification. It can include information about:

• Experiment design

• Microarrays used

• Samples used

• Sample preparation and labeling

• Hybridization procedures and parameters

• Normalization controls

• Preprocessing information

• Data processing specifications

A MIAME object includes properties and methods that let you access, retrieve,
and change experiment information related to a microarray experiment.
These properties and methods are useful to view and analyze the information.
For a list of the properties and methods, see MIAME class.

Constructing MIAME Objects
For complete information on constructing MIAME objects, see MIAME class.
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Constructing a MIAME Object from a GEO Structure

1 Import the bioma.data package so that the MIAME constructor function
is available.

import bioma.data.*

2 Use the getgeodata function to return a MATLAB structure containing
Gene Expression Omnibus (GEO) Series data related to accession number
GSE4616.

geoStruct = getgeodata('GSE4616')

geoStruct =

Header: [1x1 struct]
Data: [12488x12 bioma.data.DataMatrix]

3 Use the MIAME constructor function to create a MIAME object from the
structure.

MIAMEObj1 = MIAME(geoStruct);

4 Display information about the MIAME object, MIAMEObj.

MIAMEObj1

Experiment Description:

Author name: Mika,,Silvennoinen

Riikka,,Kivelˆ⁄

Maarit,,Lehti

Anna-Maria,,Touvras

Jyrki,,Komulainen

Veikko,,Vihko

Heikki,,Kainulainen

Laboratory: LIKES - Research Center

Contact information: Mika,,Silvennoinen

URL:

PubMedIDs: 17003243

Abstract: A 90 word abstract is available. Use the Abstract property.

Experiment Design: A 234 word summary is available. Use the ExptDesign property.
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Other notes:

[1x80 char]

Constructing a MIAME Object Using Properties

1 Import the bioma.data package so that theMIAME constructor function
is available.

import bioma.data.*

2 Use the MIAME constructor function to create a MIAME object using
individual properties.

MIAMEObj2 = MIAME('investigator', 'Jane Researcher',...

'lab', 'One Bioinformatics Laboratory',...

'contact', 'jresearcher@lab.not.exist',...

'url', 'www.lab.not.exist',...

'title', 'Normal vs. Diseased Experiment',...

'abstract', 'Example of using expression data',...

'other', {'Notes:Created from a text file.'});

3 Display information about the MIAME object, MIAMEObj2.

MIAMEObj2 =

Experiment Description:

Author name: Jane Researcher

Laboratory: One Bioinformatics Laboratory

Contact information: jresearcher@lab.not.exist

URL: www.lab.not.exist

PubMedIDs:

Abstract: A 4 word abstract is available. Use the Abstract property.

No experiment design summary available.

Other notes:

'Notes:Created from a text file.'

Using Properties and Methods of a MIAME Object
To access properties of a MIAME object, use the following syntax:

objectname.propertyname
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For example, to retrieve the PubMed identifier of publications related to a
MIAME object:

MIAMEObj.PubMedID

ans =

17003243

Note For a list and description of all properties of a MIAME object, see
MIAME class.

To use methods of a MIAME object, use either of the following syntaxes:

objectname.methodname

or

methodname(objectname)

For example, to determine if a MIAME object is empty:

MIAMEObj.isempty

ans =

0

Note For a complete list of methods of a MIAME object, see MIAME class.

3-20



Working with DataMatrix Objects

Working with DataMatrix Objects

In this section...

“Overview of DataMatrix Objects” on page 3-21

“Constructing DataMatrix Objects” on page 3-22

“Getting and Setting Properties of a DataMatrix Object” on page 3-23

“Accessing DataMatrix Objects” on page 3-24

Overview of DataMatrix Objects
The toolbox includes functions, objects, and methods for creating, storing, and
accessing microarray data.

The object constructor function, DataMatrix, lets you create a DataMatrix
object to encapsulate data and metadata from a microarray experiment. A
DataMatrix object stores experimental data in a matrix, with rows typically
corresponding to gene names or probe identifiers, and columns typically
corresponding to sample identifiers. A DataMatrix object also stores
metadata, including the gene names or probe identifiers (as the row names)
and sample identifiers (as the column names).

You can reference microarray expression values in a DataMatrix object the
same way you reference data in a MATLAB array, that is, by using linear or
logical indexing. Alternately, you can reference this experimental data by
gene (probe) identifiers and sample identifiers. Indexing by these identifiers
lets you quickly and conveniently access subsets of the data without having
to maintain additional index arrays.

Many MATLAB operators and arithmetic functions are available to
DataMatrix objects by means of methods. These methods let you modify,
combine, compare, analyze, plot, and access information from DataMatrix
objects. Additionally, you can easily extend the functionality by using
general element-wise functions, dmarrayfun and dmbsxfun, and by manually
accessing the properties of a DataMatrix object.
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Note For tables describing the properties and methods of a DataMatrix
object, see the DataMatrix object reference page.

Constructing DataMatrix Objects

1 Load the MAT-file, provided with the Bioinformatics Toolbox software, that
contains yeast data. This MAT-file includes three variables: yeastvalues,
a 614-by-7 matrix of gene expression data, genes, a cell array of 614
GenBank accession numbers for labeling the rows in yeastvalues,
and times, a 1-by-7 vector of time values for labeling the columns in
yeastvalues.

load filteredyeastdata

2 Create variables to contain a subset of the data, specifically the first five
rows and first four columns of the yeastvalues matrix, the genes cell
array, and the times vector.

yeastvalues = yeastvalues(1:5,1:4);
genes = genes(1:5,:);
times = times(1:4);

3 Import the microarray object package so that the DataMatrix constructor
function will be available.

import bioma.data.*

4 Use the DataMatrix constructor function to create a small DataMatrix
object from the gene expression data in the variables you created in step 2.

dmo = DataMatrix(yeastvalues,genes,times)

dmo =

0 9.5 11.5 13.5
SS DNA -0.131 1.699 -0.026 0.365
YAL003W 0.305 0.146 -0.129 -0.444
YAL012W 0.157 0.175 0.467 -0.379
YAL026C 0.246 0.796 0.384 0.981
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YAL034C -0.235 0.487 -0.184 -0.669

Getting and Setting Properties of a DataMatrix
Object
You use the get and set methods to retrieve and set properties of a
DataMatrix object.

1 Use the get method to display the properties of the DataMatrix object, dmo.

get(dmo)
Name: ''

RowNames: {5x1 cell}
ColNames: {' 0' ' 9.5' '11.5' '13.5'}

NRows: 5
NCols: 4
NDims: 2

ElementClass: 'double'

2 Use the set method to specify a name for the DataMatrix object, dmo.

dmo = set(dmo,'Name','MyDMObject');

3 Use the get method again to display the properties of the DataMatrix
object, dmo.

get(dmo)
Name: 'MyDMObject'

RowNames: {5x1 cell}
ColNames: {' 0' ' 9.5' '11.5' '13.5'}

NRows: 5
NCols: 4
NDims: 2

ElementClass: 'double'

Note For a description of all properties of a DataMatrix object, see the
DataMatrix object reference page.
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Accessing DataMatrix Objects
DataMatrix objects support the following types of indexing to extract, assign,
and delete data:

• Parenthesis ( ) indexing

• Dot . indexing

Parentheses () Indexing
Use parenthesis indexing to extract a subset of the data in dmo and assign
it to a new DataMatrix object dmo2:

dmo2 = dmo(1:5,2:3)
dmo2 =

9.5 11.5
SS DNA 1.699 -0.026
YAL003W 0.146 -0.129
YAL012W 0.175 0.467
YAL026C 0.796 0.384
YAL034C 0.487 -0.184

Use parenthesis indexing to extract a subset of the data using row names and
column names, and assign it to a new DataMatrix object dmo3:

dmo3 = dmo({'SS DNA','YAL012W','YAL034C'},'11.5')

dmo3 =

11.5
SS DNA -0.026
YAL012W 0.467
YAL034C -0.184

Note If you use a cell array of row names or column names to index into a
DataMatrix object, the names must be unique, even though the row names or
column names within the DataMatrix object are not unique.
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Use parenthesis indexing to assign new data to a subset of the elements in
dmo2:

dmo2({'SS DNA', 'YAL003W'}, 1:2) = [1.700 -0.030; 0.150 -0.130]
dmo2 =

9.5 11.5
SS DNA 1.7 -0.03
YAL003W 0.15 -0.13
YAL012W 0.175 0.467
YAL026C 0.796 0.384
YAL034C 0.487 -0.184

Use parenthesis indexing to delete a subset of the data in dmo2:

dmo2({'SS DNA', 'YAL003W'}, :) = []
dmo2 =

9.5 11.5
YAL012W 0.175 0.467
YAL026C 0.796 0.384
YAL034C 0.487 -0.184

Dot . Indexing

Note In the following examples, notice that when using dot indexing with
DataMatrix objects, you specify all rows or all columns using a colon within
single quotation marks, (':').

Use dot indexing to extract the data from the 11.5 column only of dmo:

timeValues = dmo.(':')('11.5')
timeValues =

-0.0260
-0.1290
0.4670
0.3840

-0.1840
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Use dot indexing to assign new data to a subset of the elements in dmo:

dmo.(1:2)(':') = 7
dmo =

0 9.5 11.5 13.5
SS DNA 7 7 7 7
YAL003W 7 7 7 7
YAL012W 0.157 0.175 0.467 -0.379
YAL026C 0.246 0.796 0.384 0.981
YAL034C -0.235 0.487 -0.184 -0.669

Use dot indexing to delete an entire variable from dmo:

dmo.YAL034C = []
dmo =

0 9.5 11.5 13.5
SS DNA 7 7 7 7
YAL003W 7 7 7 7
YAL012W 0.157 0.175 0.467 -0.379
YAL026C 0.246 0.796 0.384 0.981

Use dot indexing to delete two columns from dmo:

dmo.(':')(2:3)=[]

dmo =

0 13.5
SS DNA 7 7
YAL003W 7 7
YAL012W 0.157 -0.379
YAL026C 0.246 0.981
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Example: Visualizing Microarray Data

In this section...

“Overview of the Mouse Example” on page 3-27

“Exploring the Microarray Data Set” on page 3-28

“Spatial Images of Microarray Data” on page 3-30

“Statistics of the Microarrays” on page 3-40

“Scatter Plots of Microarray Data” on page 3-42

Overview of the Mouse Example
This example looks at the various ways to visualize microarray data. The
data comes from a pharmacological model of Parkinson’s disease (PD) using
a mouse brain. The microarray data for this example is from Brown, V.M.,
Ossadtchi, A., Khan, A.H., Yee, S., Lacan, G., Melega, W.P., Cherry, S.R.,
Leahy, R.M., and Smith, D.J.; "Multiplex three dimensional brain gene
expression mapping in a mouse model of Parkinson’s disease"; Genome
Research 12(6): 868-884 (2002).

The microarray data used in this example is available in a Web supplement
to the paper by Brown et al. and in the file mouse_a1pd.gpr included with
the Bioinformatics Toolbox software.

http://labs.pharmacology.ucla.edu/smithlab/genome_multiplex/

The microarray data is also available on the Gene Expression Omnibus Web
site at

http://www.ncbi.nlm.nih.gov/geo/query/acc.cgi?acc=GSE30

The GenePix GPR-formatted file mouse_a1pd.gpr contains the data for one
of the microarrays used in the study. This is data from voxel A1 of the brain
of a mouse in which a pharmacological model of Parkinson’s disease (PD)
was induced using methamphetamine. The voxel sample was labeled with
Cy3 (green) and the control, RNA from a total (not voxelated) normal mouse
brain, was labeled with Cy5 (red). GPR formatted files provide a large amount
of information about the array, including the mean, median, and standard
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3 Microarray Analysis

deviation of the foreground and background intensities of each spot at the
635 nm wavelength (the red, Cy5 channel) and the 532 nm wavelength (the
green, Cy3 channel).

Exploring the Microarray Data Set
This procedure illustrates how to import data from the Web into the MATLAB
environment, using data from a study about gene expression in mouse brains
as an example. See “Overview of the Mouse Example” on page 3-27.

1 Read data from a file into a MATLAB structure. For example, in the
MATLAB Command Window, type

pd = gprread('mouse_a1pd.gpr')

Information about the structure displays in the MATLAB Command
Window:

pd =
Header: [1x1 struct]

Data: [9504x38 double]
Blocks: [9504x1 double]

Columns: [9504x1 double]
Rows: [9504x1 double]

Names: {9504x1 cell}
IDs: {9504x1 cell}

ColumnNames: {38x1 cell}
Indices: [132x72 double]

Shape: [1x1 struct]

2 Access the fields of a structure using StructureName.FieldName. For
example, you can access the field ColumnNames of the structure pd by typing

pd.ColumnNames

The column names are shown below.

ans =
'X'
'Y'
'Dia.'
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'F635 Median'
'F635 Mean'
'F635 SD'
'B635 Median'
'B635 Mean'
'B635 SD'
'% > B635+1SD'
'% > B635+2SD'
'F635 % Sat.'
'F532 Median'
'F532 Mean'
'F532 SD'
'B532 Median'
'B532 Mean'
'B532 SD'
'% > B532+1SD'
'% > B532+2SD'
'F532 % Sat.'
'Ratio of Medians'
'Ratio of Means'
'Median of Ratios'
'Mean of Ratios'
'Ratios SD'
'Rgn Ratio'
'Rgn R†'
'F Pixels'
'B Pixels'
'Sum of Medians'
'Sum of Means'
'Log Ratio'
'F635 Median - B635'
'F532 Median - B532'
'F635 Mean - B635'
'F532 Mean - B532'
'Flags'

3 Access the names of the genes. For example, to list the first 20 gene names,
type

pd.Names(1:20)
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A list of the first 20 gene names is displayed:

ans =
'AA467053'
'AA388323'
'AA387625'
'AA474342'
'Myo1b'
'AA473123'
'AA387579'
'AA387314'
'AA467571'

''
'Spop'
'AA547022'
'AI508784'
'AA413555'
'AA414733'

''
'Snta1'
'AI414419'
'W14393'
'W10596'

Spatial Images of Microarray Data
This procedure illustrates how to visualize microarray data by plotting image
maps. The function maimage can take a microarray data structure and create
a pseudocolor image of the data arranged in the same order as the spots on
the array. In other words, maimage plots a spatial plot of the microarray.

This procedure uses data from a study of gene expression in mouse brains.
For a list of field names in the MATLAB structure pd, see “Exploring the
Microarray Data Set” on page 3-28.

1 Plot the median values for the red channel. For example, to plot data from
the field F635 Median, type

figure
maimage(pd,'F635 Median')
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The MATLAB software plots an image showing the median pixel values for
the foreground of the red (Cy5) channel.

2 Plot the median values for the green channel. For example, to plot data
from the field F532 Median, type

figure
maimage(pd,'F532 Median')
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The MATLAB software plots an image showing the median pixel values of
the foreground of the green (Cy3) channel.

3 Plot the median values for the red background. The field B635 Median
shows the median values for the background of the red channel.

figure
maimage(pd,'B635 Median')
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The MATLAB software plots an image for the background of the red
channel. Notice the very high background levels down the right side of
the array.

4 Plot the medial values for the green background. The field B532 Median
shows the median values for the background of the green channel.

figure
maimage(pd,'B532 Median')
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The MATLAB software plots an image for the background of the green
channel.

5 The first array was for the Parkinson’s disease model mouse. Now read in
the data for the same brain voxel but for the untreated control mouse. In
this case, the voxel sample was labeled with Cy3 and the control, total
brain (not voxelated), was labeled with Cy5.

wt = gprread('mouse_a1wt.gpr')

The MATLAB software creates a structure and displays information about
the structure.
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wt =
Header: [1x1 struct]

Data: [9504x38 double]
Blocks: [9504x1 double]

Columns: [9504x1 double]
Rows: [9504x1 double]

Names: {9504x1 cell}
IDs: {9504x1 cell}

ColumnNames: {38x1 cell}
Indices: [132x72 double]

Shape: [1x1 struct]

6 Use the function maimage to show pseudocolor images of the foreground
and background. You can use the function subplot to put all the plots
onto one figure.

figure
subplot(2,2,1);
maimage(wt,'F635 Median')
subplot(2,2,2);
maimage(wt,'F532 Median')
subplot(2,2,3);
maimage(wt,'B635 Median')
subplot(2,2,4);
maimage(wt,'B532 Median')
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The MATLAB software plots the images.

7 If you look at the scale for the background images, you will notice that the
background levels are much higher than those for the PD mouse and there
appears to be something nonrandom affecting the background of the Cy3
channel of this slide. Changing the colormap can sometimes provide more
insight into what is going on in pseudocolor plots. For more control over the
color, try the colormapeditor function.

colormap hot
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The MATLAB software plots the images.

8 The function maimage is a simple way to quickly create pseudocolor images
of microarray data. However if you want more control over plotting, it is
easy to create your own plots using the function imagesc.

First find the column number for the field of interest.

b532MedCol = find(strcmp(wt.ColumnNames,'B532 Median'))

The MATLAB software displays:

b532MedCol =
16

9 Extract that column from the field Data.

b532Data = wt.Data(:,b532MedCol);
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10 Use the field Indices to index into the Data.

figure
subplot(1,2,1);
imagesc(b532Data(wt.Indices))
axis image
colorbar
title('B532 Median')

The MATLAB software plots the image.
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11 Bound the intensities of the background plot to give more contrast in the
image.

maskedData = b532Data;
maskedData(b532Data<500) = 500;
maskedData(b532Data>2000) = 2000;

subplot(1,2,2);
imagesc(maskedData(wt.Indices))
axis image
colorbar
title('Enhanced B532 Median')

The MATLAB software plots the images.
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Statistics of the Microarrays
This procedure illustrates how to visualize distributions in microarray data.
You can use the function maboxplot to look at the distribution of data in
each of the blocks.

1 In the MATLAB Command Window, type

figure

subplot(2,1,1)

maboxplot(pd,'F532 Median','title','Parkinson''s Disease Model Mouse')

subplot(2,1,2)

maboxplot(pd,'B532 Median','title','Parkinson''s Disease Model Mouse')

figure

subplot(2,1,1)

maboxplot(wt,'F532 Median','title','Untreated Mouse')

subplot(2,1,2)

maboxplot(wt,'B532 Median','title','Untreated Mouse')

The MATLAB software plots the images.
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2 Compare the plots.

From the box plots you can clearly see the spatial effects in the background
intensities. Blocks numbers 1, 3, 5, and 7 are on the left side of the
arrays, and numbers 2, 4, 6, and 8 are on the right side. The data must be
normalized to remove this spatial bias.

Scatter Plots of Microarray Data
This procedure illustrates how to visualize expression levels in microarray
data. There are two columns in the microarray data structure labeled 'F635
Median - B635' and 'F532 Median - B532'. These columns are the
differences between the median foreground and the median background for
the 635 nm channel and 532 nm channel respectively. These give a measure of
the actual expression levels, although since the data must first be normalized
to remove spatial bias in the background, you should be careful about using
these values without further normalization. However, in this example no
normalization is performed.
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1 Rather than working with data in a larger structure, it is often easier to
extract the column numbers and data into separate variables.

cy5DataCol = find(strcmp(wt.ColumnNames,'F635 Median - B635'))
cy3DataCol = find(strcmp(wt.ColumnNames,'F532 Median - B532'))
cy5Data = pd.Data(:,cy5DataCol);
cy3Data = pd.Data(:,cy3DataCol);

The MATLAB software displays:

cy5DataCol =
34

cy3DataCol =
35

2 A simple way to compare the two channels is with a loglog plot. The
function maloglog is used to do this. Points that are above the diagonal in
this plot correspond to genes that have higher expression levels in the A1
voxel than in the brain as a whole.

figure
maloglog(cy5Data,cy3Data)
xlabel('F635 Median - B635 (Control)');
ylabel('F532 Median - B532 (Voxel A1)');

The MATLAB software displays the following messages and plots the
images.

Warning: Zero values are ignored
(Type "warning off Bioinfo:MaloglogZeroValues" to suppress
this warning.)

Warning: Negative values are ignored.
(Type "warning off Bioinfo:MaloglogNegativeValues" to suppress
this warning.)
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Notice that this function gives some warnings about negative and zero
elements. This is because some of the values in the 'F635 Median - B635'
and 'F532 Median - B532' columns are zero or even less than zero. Spots
where this happened might be bad spots or spots that failed to hybridize.
Points with positive, but very small, differences between foreground and
background should also be considered to be bad spots.

3 Disable the display of warnings by using the warning command. Although
warnings can be distracting, it is good practice to investigate why the
warnings occurred rather than simply to ignore them. There might be some
systematic reason why they are bad.

warnState = warning; % First save the current warning
state.

% Now turn off the two warnings.
warning('off','Bioinfo:MaloglogZeroValues');
warning('off','Bioinfo:MaloglogNegativeValues');
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figure
maloglog(cy5Data,cy3Data) % Create the loglog plot
warning(warnState); % Reset the warning state.
xlabel('F635 Median - B635 (Control)');
ylabel('F532 Median - B532 (Voxel A1)');

The MATLAB software plots the image.

4 An alternative to simply ignoring or disabling the warnings is to remove
the bad spots from the data set. You can do this by finding points where
either the red or green channel has values less than or equal to a threshold
value. For example, use a threshold value of 10.

threshold = 10;
badPoints = (cy5Data <= threshold) | (cy3Data <= threshold);
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The MATLAB software plots the image.

5 You can then remove these points and redraw the loglog plot.

cy5Data(badPoints) = []; cy3Data(badPoints) = [];
figure
maloglog(cy5Data,cy3Data)
xlabel('F635 Median - B635 (Control)');
ylabel('F532 Median - B532 (Voxel A1)');
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The MATLAB software plots the image.

This plot shows the distribution of points but does not give any indication
about which genes correspond to which points.

6 Add gene labels to the plot. Because some of the data points have
been removed, the corresponding gene IDs must also be removed from
the data set before you can use them. The simplest way to do that is
wt.IDs(~badPoints).

maloglog(cy5Data,cy3Data,'labels',wt.IDs(~badPoints),...
'factorlines',2)

xlabel('F635 Median - B635 (Control)');
ylabel('F532 Median - B532 (Voxel A1)');
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The MATLAB software plots the image.

7 Try using the mouse to click some of the outlier points.

You will see the gene ID associated with the point. Most of the outliers are
below the y = x line. In fact, most of the points are below this line. Ideally
the points should be evenly distributed on either side of this line.

8 Normalize the points to evenly distribute them on either side of the line.
Use the function mameannorm to perform global mean normalization.

normcy5 = mameannorm(cy5Data);
normcy3 = mameannorm(cy3Data);

If you plot the normalized data you will see that the points are more evenly
distributed about the y = x line.

figure
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maloglog(normcy5,normcy3,'labels',wt.IDs(~badPoints),...
'factorlines',2)

xlabel('F635 Median - B635 (Control)');
ylabel('F532 Median - B532 (Voxel A1)');

The MATLAB software plots the image.

9 The function mairplot is used to create an Intensity vs. Ratio plot for the
normalized data. This function works in the same way as the function
maloglog.

figure
mairplot(normcy5,normcy3,'labels',wt.IDs(~badPoints),...

'factorlines',2)
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The MATLAB software plots the image.

10 You can click the points in this plot to see the name of the gene associated
with the plot.
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Example: Analyzing Gene Expression Profiles

In this section...

“Overview of the Yeast Example” on page 3-51

“Exploring the Data Set” on page 3-51

“Filtering Genes” on page 3-55

“Clustering Genes” on page 3-58

“Principal Component Analysis” on page 3-62

Overview of the Yeast Example
This example demonstrates a number of ways to look for patterns in gene
expression profiles, using gene expression data from yeast shifting from
fermentation to respiration.

The microarray data for this example is from DeRisi, J.L., Iyer, V.R., and
Brown, P.O. (Oct 24, 1997). Exploring the metabolic and genetic control of
gene expression on a genomic scale. Science, 278 (5338), 680–686. PMID:
9381177.

The authors used DNA microarrays to study temporal gene expression of
almost all genes in Saccharomyces cerevisiae during the metabolic shift from
fermentation to respiration. Expression levels were measured at seven time
points during the diauxic shift. The full data set can be downloaded from the
Gene Expression Omnibus Web site at:

http://www.ncbi.nlm.nih.gov/geo/query/acc.cgi?acc=GSE28

Exploring the Data Set
This procedure illustrates how to import data from the Web into the MATLAB
environment. The data for this procedure is available in the MAT-file
yeastdata.mat. This file contains the VALUE data or LOG_RAT2N_MEAN,
or log2 of ratio of CH2DN_MEAN and CH1DN_MEAN from the seven time
steps in the experiment, the names of the genes, and an array of the times at
which the expression levels were measured.

1 Load data into the MATLAB environment.
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load yeastdata.mat

2 Get the size of the data by typing

numel(genes)

The number of genes in the data set displays in the MATLAB Command
Window. The MATLAB variable genes is a cell array of the gene names.

ans =
6400

3 Access the entries using cell array indexing.

genes{15}

This displays the 15th row of the variable yeastvalues, which contains
expression levels for the open reading frame (ORF) YAL054C.

ans =
YAL054C

4 Use the function web to access information about this ORF in the
Saccharomyces Genome Database (SGD).

url = sprintf(...
'http://genome-www4.stanford.edu/cgi-bin/SGD/...
locus.pl?locus=%s',...

genes{15});
web(url);

5 A simple plot can be used to show the expression profile for this ORF.

plot(times, yeastvalues(15,:))
xlabel('Time (Hours)');
ylabel('Log2 Relative Expression Level');
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The MATLAB software plots the figure. The values are log2 ratios.

6 Plot the actual values.

plot(times, 2.^yeastvalues(15,:))
xlabel('Time (Hours)');
ylabel('Relative Expression Level');
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The MATLAB software plots the figure. The gene associated with this
ORF, ACS1, appears to be strongly up-regulated during the diauxic shift.

7 Compare other genes by plotting multiple lines on the same figure.

hold on
plot(times, 2.^yeastvalues(16:26,:)')
xlabel('Time (Hours)');
ylabel('Relative Expression Level');
title('Profile Expression Levels');
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The MATLAB software plots the image.

Filtering Genes
This procedure illustrates how to filter the data by removing genes that are
not expressed or do not change. The data set is quite large and a lot of the
information corresponds to genes that do not show any interesting changes
during the experiment. To make it easier to find the interesting genes, reduce
the size of the data set by removing genes with expression profiles that do not
show anything of interest. There are 6400 expression profiles. You can use
a number of techniques to reduce the number of expression profiles to some
subset that contains the most significant genes.

1 If you look through the gene list you will see several spots marked as
'EMPTY'. These are empty spots on the array, and while they might have
data associated with them, for the purposes of this example, you can
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consider these points to be noise. These points can be found using the
strcmp function and removed from the data set with indexing commands.

emptySpots = strcmp('EMPTY',genes);
yeastvalues(emptySpots,:) = [];
genes(emptySpots) = [];
numel(genes)

The MATLAB software displays:

ans =
6314

In the yeastvalues data you will also see several places where the
expression level is marked as NaN. This indicates that no data was collected
for this spot at the particular time step. One approach to dealing with
these missing values would be to impute them using the mean or median of
data for the particular gene over time. This example uses a less rigorous
approach of simply throwing away the data for any genes where one or
more expression levels were not measured.

2 Use the isnan function to identify the genes with missing data and then
use indexing commands to remove the genes.

nanIndices = any(isnan(yeastvalues),2);
yeastvalues(nanIndices,:) = [];
genes(nanIndices) = [];
numel(genes)

The MATLAB software displays:

ans =
6276

If you were to plot the expression profiles of all the remaining profiles,
you would see that most profiles are flat and not significantly different
from the others. This flat data is obviously of use as it indicates that the
genes associated with these profiles are not significantly affected by the
diauxic shift. However, in this example, you are interested in the genes
with large changes in expression accompanying the diauxic shift. You can
use filtering functions in the toolbox to remove genes with various types
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of profiles that do not provide useful information about genes affected by
the metabolic change.

3 Use the function genevarfilter to filter out genes with small variance
over time. The function returns a logical array of the same size as the
variable genes with ones corresponding to rows of yeastvalues with
variance greater than the 10th percentile and zeros corresponding to those
below the threshold.

mask = genevarfilter(yeastvalues);
% Use the mask as an index into the values to remove the
% filtered genes.
yeastvalues = yeastvalues(mask,:);
genes = genes(mask);
numel(genes)

The MATLAB software displays:

ans =
5648

4 The function genelowvalfilter removes genes that have very low
absolute expression values. Note that the gene filter functions can also
automatically calculate the filtered data and names.

[mask, yeastvalues, genes] = genelowvalfilter(yeastvalues,genes,...
'absval',log2(4));

numel(genes)

The MATLAB software displays:

ans =
423

5 Use the function geneentropyfilter to remove genes whose profiles have
low entropy:

[mask, yeastvalues, genes] = geneentropyfilter(yeastvalues,genes,...
'prctile',15);

numel(genes)
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The MATLAB software displays:

ans = 310

Clustering Genes
Now that you have a manageable list of genes, you can look for relationships
between the profiles using some different clustering techniques from the
Statistics Toolbox software.

1 For hierarchical clustering, the function pdist calculates the pairwise
distances between profiles, and the function linkage creates the
hierarchical cluster tree.

corrDist = pdist(yeastvalues, 'corr');
clusterTree = linkage(corrDist, 'average');

2 The function cluster calculates the clusters based on either a cutoff
distance or a maximum number of clusters. In this case, the 'maxclust'
option is used to identify 16 distinct clusters.

clusters = cluster(clusterTree, 'maxclust', 16);

3 The profiles of the genes in these clusters can be plotted together using a
simple loop and the function subplot.

figure
for c = 1:16

subplot(4,4,c);
plot(times,yeastvalues((clusters == c),:)');
axis tight

end
suptitle('Hierarchical Clustering of Profiles');

The MATLAB software plots the images.
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4 The Statistics Toolbox software also has a K-means clustering function.
Again, 16 clusters are found, but because the algorithm is different these
are not necessarily the same clusters as those found by hierarchical
clustering.

[cidx, ctrs] = kmeans(yeastvalues, 16,...
'dist','corr',...
'rep',5,...
'disp','final');

figure
for c = 1:16

subplot(4,4,c);
plot(times,yeastvalues((cidx == c),:)');
axis tight

end
suptitle('K-Means Clustering of Profiles');
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The MATLAB software displays:

13 iterations, total sum of distances = 11.4042
14 iterations, total sum of distances = 8.62674
26 iterations, total sum of distances = 8.86066
22 iterations, total sum of distances = 9.77676
26 iterations, total sum of distances = 9.01035

5 Instead of plotting all of the profiles, you can plot just the centroids.

figure
for c = 1:16

subplot(4,4,c);
plot(times,ctrs(c,:)');
axis tight
axis off % turn off the axis

end
suptitle('K-Means Clustering of Profiles');
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The MATLAB software plots the figure:

6 You can use the function clustergram to create a heat map and
dendrogram from the output of the hierarchical clustering.

figure
clustergram(yeastvalues(:,2:end),'RowLabels',genes,...

'ColumnLabels',times(2:end))
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The MATLAB software plots the figure:

Principal Component Analysis
Principal-component analysis (PCA) is a useful technique you can use to
reduce the dimensionality of large data sets, such as those from microarray
analysis. You can also use PCA to find signals in noisy data.

1 Use the princomp function in the Statistics Toolbox software to calculate
the principal components of a data set.

[pc, zscores, pcvars] = princomp(yeastvalues)

The MATLAB software displays:

pc =

Columns 1 through 4
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-0.0245 -0.3033 -0.1710 -0.2831
0.0186 -0.5309 -0.3843 -0.5419
0.0713 -0.1970 0.2493 0.4042
0.2254 -0.2941 0.1667 0.1705
0.2950 -0.6422 0.1415 0.3358
0.6596 0.1788 0.5155 -0.5032
0.6490 0.2377 -0.6689 0.2601

Columns 5 through 7

-0.1155 0.4034 0.7887
-0.2384 -0.2903 -0.3679
-0.7452 -0.3657 0.2035
-0.2385 0.7520 -0.4283
0.5592 -0.2110 0.1032

-0.0194 -0.0961 0.0667
-0.0673 -0.0039 0.0521

2 You can use the function cumsum to see the cumulative sum of the variances.

cumsum(pcvars./sum(pcvars) * 100)

The MATLAB software displays:

ans =
78.3719
89.2140
93.4357
96.0831
98.3283
99.3203

100.0000

This shows that almost 90% of the variance is accounted for by the first
two principal components.

3 A scatter plot of the scores of the first two principal components shows that
there are two distinct regions. This is not unexpected, because the filtering
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process removed many of the genes with low variance or low information.
These genes would have appeared in the middle of the scatter plot.

figure
scatter(zscores(:,1),zscores(:,2));
xlabel('First Principal Component');
ylabel('Second Principal Component');
title('Principal Component Scatter Plot');

The MATLAB software plots the figure:

4 The gname function from the Statistics Toolbox software can be used to
identify genes on a scatter plot. You can select as many points as you like
on the scatter plot.

gname(genes);

When you have finished selecting points, press Enter.

5 An alternative way to create a scatter plot is with the gscatter function
from the Statistics Toolbox software. gscatter creates a grouped scatter
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plot where points from each group have a different color or marker. You
can use clusterdata, or any other clustering function, to group the points.

figure
pcclusters = clusterdata(zscores(:,1:2),6);
gscatter(zscores(:,1),zscores(:,2),pcclusters)
xlabel('First Principal Component');
ylabel('Second Principal Component');
title('Principal Component Scatter Plot with Colored Clusters');
gname(genes) % Press enter when you finish selecting genes.

The MATLAB software plots the figure:
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4 Phylogenetic Analysis

Overview of Phylogenetic Analysis
Phylogenetic analysis is the process you use to determine the evolutionary
relationships between organisms. The results of an analysis can be drawn
in a hierarchical diagram called a cladogram or phylogram (phylogenetic
tree). The branches in a tree are based on the hypothesized evolutionary
relationships (phylogeny) between organisms. Each member in a branch, also
known as a monophyletic group, is assumed to be descended from a common
ancestor. Originally, phylogenetic trees were created using morphology, but
now, determining evolutionary relationships includes matching patterns in
nucleic acid and protein sequences.
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Example: Building a Phylogenetic Tree

In this section...

“Overview of the Primate Example” on page 4-3

“Searching NCBI for Phylogenetic Data” on page 4-5

“Creating a Phylogenetic Tree for Five Species” on page 4-6

“Creating a Phylogenetic Tree for Twelve Species” on page 4-9

“Exploring the Phylogenetic Tree” on page 4-11

Note For information on creating a phylogenetic tree with multiply aligned
sequences, see the phytree function.

Overview of the Primate Example
In this example, a phylogenetic tree is constructed from mitochondrial DNA
(mtDNA) sequences for the family Hominidae. This family includes gorillas,
chimpanzees, orangutans, and humans.

The following procedures demonstrate the phylogenetic analysis features
in the Bioinformatics Toolbox software. They are not intended to teach the
process of phylogenetic analysis, but to show you how to use MathWorks
products to create a phylogenetic tree from a set of nonaligned nucleotide
sequences.

The origin of modern humans is a heavily debated issue that scientists have
recently tackled by using mitochondrial DNA (mtDNA) sequences. One
hypothesis explains the limited genetic variation of human mtDNA in terms
of a recent common genetic ancestry, implying that all modern population
mtDNA originated from a single woman who lived in Africa less than 200,000
years ago.

Why Use Mitochondrial DNA Sequences for Phylogenetic
Study?
Mitochondrial DNA sequences, like the Y chromosome, do not recombine
and are inherited from the maternal parent. This lack of recombination
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allows sequences to be traced through one genetic line and all polymorphisms
assumed to be caused by mutations.

Mitochondrial DNA in mammals has a faster mutation rate than nuclear
DNA sequences. This faster rate of mutation produces more variance between
sequences and is an advantage when studying closely related species. The
mitochondrial control region (Displacement or D-loop) is one of the fastest
mutating sequence regions in animal DNA.

Neanderthal DNA
The ability to isolate mitochondrial DNA (mtDNA) from palaeontological
samples has allowed genetic comparisons between extinct species and closely
related nonextinct species. The reasons for isolating mtDNA instead of
nuclear DNA in fossil samples have to do with the fact that:

• mtDNA, because it is circular, is more stable and degrades slower then
nuclear DNA.

• Each cell can contain a thousand copies of mtDNA and only a single copy
of nuclear DNA.

While there is still controversy as to whether Neanderthals are direct
ancestors of humans or evolved independently, the use of ancient genetic
sequences in phylogenetic analysis adds an interesting dimension to the
question of human ancestry.

References
Ovchinnikov I., et al. (2000). Molecular analysis of Neanderthal DNA from
the northern Caucasus. Nature 404(6777), 490–493.

Sajantila A., et al. (1995). Genes and languages in Europe: an analysis of
mitochondrial lineages. Genome Research 5 (1), 42–52.

Krings M., et al. (1997). Neanderthal DNA sequences and the origin of
modern humans. Cell 90 (1), 19–30.

Jensen-Seaman, M., Kidd K. (2001). Mitochondrial DNA variation and
biogeography of eastern gorillas. Molecular Ecology 10(9), 2241–2247.
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Searching NCBI for Phylogenetic Data
The NCBI taxonomy Web site includes phylogenetic and taxonomic
information from many sources. These sources include the published
literature, Web databases, and taxonomy experts. And while the NCBI
taxonomy database is not a phylogenetic or taxonomic authority, it can be
useful as a gateway to the NCBI biological sequence databases.

This procedure uses the family Hominidae (orangutans, chimpanzees,
gorillas, and humans) as a taxonomy example for searching the NCBI Web
site and locating mitochondrial D-loop sequences.

1 Use the MATLAB Help browser to search for data on the Web. In the
MATLAB Command Window, type

web('http://www.ncbi.nlm.nih.gov')

A separate browser window opens with the home page for the NCBI Web
site.

2 Search the NCBI Web site for information. For example, to search for the
human taxonomy, from the Search list, select Taxonomy, and in the for
box, enter hominidae.

The NCBI Web search returns a list of links to relevant pages.
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3 Select the taxonomy link for the family Hominidae. A page with the
taxonomy for the family is shown.

Creating a Phylogenetic Tree for Five Species
Drawing a phylogenetic tree using sequence data is helpful when you are
trying to visualize the evolutionary relationships between species. The
sequences can be multiply aligned or a set of nonaligned sequences, you can
select a method for calculating pairwise distances between sequences, and
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you can select a method for calculating the hierarchical clustering distances
used to build a tree.

After locating the GenBank accession codes for the sequences you are
interested in studying, you can create a phylogenetic tree with the data. For
information on locating accession codes, see “Searching NCBI for Phylogenetic
Data” on page 4-5.

In the following example, you will use the Jukes-Cantor method to calculate
distances between sequences, and the Unweighted Pair Group Method
Average (UPGMA) method for linking the tree nodes.

1 Create a MATLAB structure with information about the sequences. This
step uses the accession codes for the mitochondrial D-loop sequences
isolated from different hominid species.

data = {'German_Neanderthal' 'AF011222';
'Russian_Neanderthal' 'AF254446';
'European_Human' 'X90314' ;
'Mountain_Gorilla_Rwanda' 'AF089820';
'Chimp_Troglodytes' 'AF176766';

};

2 Retrieve sequence data from the GenBank database and copy into the
MATLAB environment.

for ind = 1:5
seqs(ind).Header = data{ind,1};
seqs(ind).Sequence = getgenbank(data{ind,2},...

'sequenceonly', true);
end

3 Calculate pairwise distances and create a phytree object. For example,
compute the pairwise distances using the Jukes-Cantor distance method
and build a phylogenetic tree using the UPGMA linkage method. Since
the sequences are not prealigned, seqpdist pairwise aligns them before
computing the distances.

distances = seqpdist(seqs,'Method','Jukes-Cantor','Alphabet','DNA');
tree = seqlinkage(distances,'UPGMA',seqs)
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The MATLAB software displays information about the phytree object.
The function seqpdist calculates the pairwise distances between pairs of
sequences while the function seqlinkage uses the distances to build a
hierarchical cluster tree. First, the most similar sequences are grouped
together, and then sequences are added to the tree in descending order
of similarity.

Phylogenetic tree object with 5 leaves (4 branches)

4 Draw a phylogenetic tree.

h = plot(tree,'orient','bottom');
ylabel('Evolutionary distance')
set(h.terminalNodeLabels,'Rotation',-45)

The MATLAB software draws a phylogenetic tree in a Figure window. In
the figure below, the hypothesized evolutionary relationships between the
species is shown by the location of species on the branches. The horizontal
distances do not have any biological significance.
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Creating a Phylogenetic Tree for Twelve Species
Plotting a simple phylogenetic tree for five species seems to indicate a number
of monophyletic groups (see “Creating a Phylogenetic Tree for Five Species”
on page 4-6). After a preliminary analysis with five species, you can add more
species to your phylogenetic tree. Adding more species to the data set will
help you to confirm the observed monophyletic groups are valid.

1 Add more sequences to a MATLAB structure. For example, add mtDNA
D-loop sequences for other hominid species.

data2 = {'Puti_Orangutan' 'AF451972';
'Jari_Orangutan' 'AF451964';
'Western_Lowland_Gorilla' 'AY079510';
'Eastern_Lowland_Gorilla' 'AF050738';
'Chimp_Schweinfurthii' 'AF176722';
'Chimp_Vellerosus' 'AF315498';
'Chimp_Verus' 'AF176731';

};
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2 Get additional sequence data from the GenBank database, and copy the
data into the next indices of a MATLAB structure.

for ind = 1:7
seqs(ind+5).Header = data2{ind,1};
seqs(ind+5).Sequence = getgenbank(data2{ind,2},...

'sequenceonly', true);
end

3 Calculate pairwise distances and the hierarchical linkage.

distances = seqpdist(seqs,'Method','Jukes-Cantor','Alpha','DNA');
tree = seqlinkage(distances,'UPGMA',seqs);

4 Draw a phylogenetic tree.

h = plot(tree,'orient','bottom');
ylabel('Evolutionary distance')
set(h.terminalNodeLabels,'Rotation',-45)

The MATLAB software draws a phylogenetic tree in a Figure window. You
can see four main clades for humans, gorillas, chimpanzee, and orangutans.
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Exploring the Phylogenetic Tree
After you create a phylogenetic tree, you can explore the tree using the
MATLAB command line or the phytreetool GUI. This procedure uses the
tree created in “Creating a Phylogenetic Tree for Twelve Species” on page
4-9 as an example.

1 List the members of a tree.

names = get(tree,'LeafNames')

From the list, you can determine the indices for its members. For example,
the European Human leaf is the third entry.

names =

'German_Neanderthal'
'Russian_Neanderthal'
'European_Human'
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'Chimp_Troglodytes'
'Chimp_Schweinfurthii'
'Chimp_Verus'
'Chimp_Vellerosus'
'Puti_Orangutan'
'Jari_Orangutan'
'Mountain_Gorilla_Rwanda'
'Eastern_Lowland_Gorilla'
'Western_Lowland_Gorilla'

2 Find the closest species to a selected species in a tree. For example, find
the species closest to the European human.

[h_all,h_leaves] = select(tree,'reference',3,...
'criteria','distance',...
'threshold',0.6);

h_all is a list of indices for the nodes within a patristic distance of 0.6 to
the European human leaf, while h_leaves is a list of indices for only the
leaf nodes within the same patristic distance.

A patristic distance is the path length between species calculated from
the hierarchical clustering distances. The path distance is not necessarily
the biological distance.

3 List the names of the closest species.

subtree_names = names(h_leaves)

The MATLAB software prints a list of species with a patristic distance to
the European human less than the specified distance. In this case, the
patristic distance threshold is less than 0.6.

subtree_names =

'German_Neanderthal'
'Russian_Neanderthal'
'European_Human'
'Chimp_Schweinfurthii'
'Chimp_Verus'
'Chimp_Troglodytes'
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4 Extract a subtree from the whole tree by removing unwanted leaves. For
example, prune the tree to species within 0.6 of the European human
species.

leaves_to_prune = ~h_leaves;
pruned_tree = prune(tree,leaves_to_prune)
h = plot(pruned_tree,'orient','bottom');
ylabel('Evolutionary distance')
set(h.terminalNodeLabels,'Rotation',-30)

The MATLAB software returns information about the new subtree and
plots the pruned phylogenetic tree in a Figure window.

Phylogenetic tree object with 6 leaves (5 branches)

5 Explore, edit, and format a phylogenetic tree using an interactive GUI.

phytreetool(pruned_tree)

The Phylogenetic Tree Tool window opens and draws the tree.
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You can interactively change the appearance of the tree within the tool
window. For information on using this GUI, see “Phylogenetic Tree Tool
Reference” on page 4-15.
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Phylogenetic Tree Tool Reference

In this section...

“Overview of the Phylogenetic Tree Tool” on page 4-15

“Opening the Phylogenetic Tree Tool” on page 4-15

“File Menu” on page 4-17

“Tools Menu” on page 4-30

“Window Menu” on page 4-39

“Help Menu” on page 4-40

Overview of the Phylogenetic Tree Tool
The Phylogenetic Tree Tool is an interactive graphical user interface (GUI)
that allows you to view, edit, format, and explore phylogenetic tree data. With
this GUI you can prune, reorder, rename branches, and explore distances.
You can also open or save Newick-formatted files. The following sections
give a description of menu commands and features for creating publishable
tree figures.

Opening the Phylogenetic Tree Tool
This section illustrates how to draw a phylogenetic tree from data in a phytree
object or a previously saved file.

The Phylogenetic Tree Tool can read data from Newick and ClustalW tree
formatted files.

This procedure uses the phylogenetic tree data stored in the file pf00002.tree
as an example. The data was retrieved from the protein family (PFAM) Web
database and saved to a file using the accession number PF00002 and the
function gethmmtree.

1 Create a phytree object. For example, to create a phytree object from tree
data in the file pf00002.tree, type

tr= phytreeread('pf00002.tree')
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The MATLAB software creates a phytree object.

Phylogenetic tree object with 37 leaves (36 branches)

2 Open the Phylogenetic Tree Tool and draw a phylogenetic tree.

phytreetool(tr)

The Phylogenetic Tree Tool window opens.
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Alternately, if you do not give the phytreetool function an argument, the
Select Phylogenetic Tree dialog box opens. Select a Newick-formatted file
and then click Open.

3 Select a command from the menu or toolbar.

File Menu
This section illustrates how to

The File menu includes the standard commands for opening and closing a
file, and it includes commands to use phytree object data from the MATLAB
Workspace. The File menu commands are shown below.
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New Tool Command
Use the New Tool command to open tree data from a file into a second
Phylogenetic Tree Tool window.

1 From the File menu, select New Tool.

The Open A Phylogenetic Tree dialog box opens.

2 Choose the source for a tree.

• MATLAB Workspace — Select the Import from Workspace options,
and then select a phytree object from the list.

• File — Select the Open phylogenetic tree file option, click the
Browse button, select a directory, select a file with the extension .tree,
and then click Open. The toolbox uses the file extension .tree for
Newick-formatted files, but you can use any Newick-formatted file with
any extension.
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A second Phylogenetic Tree Tool window opens with tree data from the
selected file.

Open Command
Use the Open command to read tree data from a Newick-formatted file and
display that data in a Phylogenetic Tree Tool.

1 From the File menu, click Open.

The Select Phylogenetic Tree File dialog box opens.

2 Select a directory, select a Newick-formatted file, and then click Open. The
toolbox uses the file extension .tree for Newick-formatted files, but you
can use any Newick-formatted file with any extension.

The MATLAB software replaces the current tree data with data from the
selected file.

Import from Workspace Command
Use the Import from Workspace command to read tree data from a phytree
object in the MATLAB Workspace and display that data in a Phylogenetic
Tree Tool.

4-19



4 Phylogenetic Analysis

1 From the File menu, select Import from Workspace.

The Get Phytree Object dialog box opens.

2 From the list, select a phytree object in the MATLAB Workspace.

3 Click the Import button.

The MATLAB software replaces the current tree data in the Phylogenetic
Tree Tool with data from the selected object.

Open Original in New Tool
There may be times when you make changes that you would like to undo.
Phytreetool does not have an undo command, but you can get back to the
original tree you started viewing with the Open Original in New Tool
command.

From the File menu, select Open Original in New Tool.

A new Phylogenetic Tree Tool window opens with the original tree.

Save As Command
After you create a phytree object or prune a tree from existing data, you can
save the resulting tree in a Newick-formatted file. The sequence data used to
create the phytree object is not saved with the tree.
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1 From the File menu, select Save As.

The Save Phylogenetic tree as dialog box opens.

2 In the Filename box, enter the name of a file. The toolbox uses the file
extension .tree for Newick-formatted files, but you can use any file
extension.

3 Click Save.

phytreetool saves tree data without the deleted branches, and it saves
changes to branch and leaf names. Formatting changes such as branch
rotations, collapsed branches, and zoom settings are not saved in the file.

Export to New Tool Command
Because some of the Phylogenetic Tree Tool commands cannot be undone (for
example, the Prune command), you might want to make a copy of your tree
before trying a command. At other times, you might want to compare two
views of the same tree, and copying a tree to a new tool window allows you to
make changes to both tree views independently .

1 Select File > Export to New Tool, and then select either With Hidden
Nodes or Only Displayed.

A new Phylogenetic Tree Tool window opens with a copy of the tree.

2 Use the new figure to continue your analysis.

Export to Workspace Command
The Phylogenetic Tree Tool can open Newick-formatted files with tree data.
However, it does not create a phytree object in the MATLAB Workspace. If
you want to programmatically explore phylogenetic trees, you need to use the
Export to Workspace command.

1 Select File > Export to Workspace, and then select eitherWith Hidden
Nodes or Only Displayed.

The Export to Workspace dialog box opens.
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2 In the Workspace variable name box, enter the name for your
phylogenetic tree data. For example, enter MyTree.

3 Click OK.

The phytreetool creates a phytree object in the MATLAB Workspace.

Print to Figure Command
After you have explored the relationships between branches and leaves in
your tree, you can copy the tree to a MATLAB Figure window. Using a
Figure window lets you use all the features for annotating, changing font
characteristics, and getting your figure ready for publication. Also, from the
Figure window, you can save an image of the tree as it was displayed in the
Phylogenetic Tree Tool window.

1 From the File menu, select Print to Figure, and then select eitherWith
Hidden Nodes or Only Displayed.

The Publish Phylogenetic Tree to Figure dialog box opens.
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2 Select one of the Rendering Types.
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Rendering Type Description

'square' (default)
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Rendering Type Description

'angular'
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Rendering Type Description

'radial'

'equalangle'
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Rendering Type Description

Tip This rendering type hides the significance of
the root node and emphasizes clusters, thereby
making it useful for visually assessing clusters
and detecting outliers.

'equaldaylight'

Tip This rendering type hides the significance of
the root node and emphasizes clusters, thereby
making it useful for visually assessing clusters
and detecting outliers.

3 Select the Display Labels you want on your figure. You can select from all
to none of the options.

• Branch Nodes— Display branch node names on the figure.

• Leaf Nodes — Display leaf node names on the figure.

• Terminal Nodes— Display terminal node names on the right border.
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4 Click the Print button.

A new Figure window opens with the characteristics you selected.

Page Setup Command
When you print from the Phylogenetic Tree Tool or a MATLAB Figure
window (with a tree published from the tool), you can specify setup options for
printing a tree.

1 From the File menu, select Page Setup.

The Page Setup - Phylogenetic Tree Tool dialog box opens, which you can
use to select page formatting options.

2 Select the page formatting options and values you want, and then click OK.
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Print Setup Command
Use the Print Setup command with the Page Setup command to print a
MATLAB Figure window.

1 From the File menu, select Print Setup.

The Print Setup dialog box opens.

2 Select the printer and options you want, and then click OK.

Print Preview Command
Use the Print Preview command to check the formatting options you
selected with the Page Setup commend.

1 From the File menu, select Print Preview.

A window opens with a picture of your figure with the selected formatting
options.
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2 Click Print or Close.

Print Command
Use the Print command to make a copy of your phylogenetic tree after you
use the Page Setup command to select formatting options.

1 From the File menu, select Print.

The Print dialog box opens.

2 From the Name list, select a printer, and then click OK.

Tools Menu
Use the Tools menu to:

• Explore branch paths

• Rotate branches

• Find, rename, hide, and prune branches and leaves.

The Tools menu and toolbar contain most of the commands specific to trees
and phylogenetic analysis. Use these commands and modes to edit and format
your tree interactively. The Tools menu commands are:
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Inspect Mode
Viewing a phylogenetic tree in the Phylogenetic Tree Tool window provides a
rough idea of how closely related two sequences are. However, to see exactly
how closely related two sequences are, measure the distance of the path
between them. Use the Inspect command to display and measure the path
between two sequences.

1 Select Tools > Inspect, or from the toolbar, click the Inspect Tool Mode

icon .

The Phylogenetic Tree Tool is set to inspect mode.

2 Click a branch or leaf node (selected node), and then hover your cursor over
another branch or leaf node (current node).
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The tool highlights the path between the two nodes and displays the path
length in the pop-up window. The path length is the patristic distance
calculated by the seqpdist function.

Collapse and Expand Branch Mode
Some trees have thousands of leaf and branch nodes. Displaying all the nodes
can create an unreadable tree diagram. By collapsing some branches, you can
better see the relationships between the remaining nodes.

1 Select Tools > Collapse/Expand, or from the toolbar, click the

Collapse/Expand Brand Mode icon .

The Phylogenetic Tree Tool is set to collapse/expand mode.

2 Point to a branch.

The paths, branch nodes, and leaf nodes below the selected branch appear
in gray, indicating you selected them to collapse (hide from view).

3 Click the branch node.

The tool hides the display of paths, branch nodes, and leaf nodes below the
selected branch. However, it does not remove the data.
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4 To expand a collapsed branch, click it or select Tools > Reset View.

Tip After collapsing nodes, you can redraw the tree by selecting Tools >
Fit to Window.

Rotate Branch Mode
A phylogenetic tree is initially created by pairing the two most similar
sequences and then adding the remaining sequences in a decreasing order of
similarity. You can rotate branches to emphasize the direction of evolution.

1 Select Tools > Rotate Branch, or from the toolbar, click the Rotate

Branch Mode icon .

The Phylogenetic Tree Tool is set to rotate branch mode.

2 Point to a branch node.

3 Click the branch node.
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The branch and leaf nodes below the selected branch node rotate 180
degrees around the branch node.

4 To undo the rotation, simply click the branch node again, or select Tools
> Reset View.

Rename Leaf or Branch Mode
The Phylogenetic Tree Tool takes the node names from the phytree object and
creates numbered branch names starting with Branch 1. You can edit any
of the leaf or branch names.

1 Select Tools > Rename, or from the toolbar, click the Rename Leaf/Branch

Mode icon .

The Phylogenetic Tree Tool is set to rename mode.

2 Click a branch or leaf node.

A text box opens with the current name of the node.

3 In the text box, edit or enter a new name.

4 To accept your changes and close the text box, click outside of the text box.
To save your changes, select File > Save As.
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Prune (Delete) Leaf or Branch Mode
Your tree can contain leaves that are far outside the phylogeny, or it can have
duplicate leaves that you want to remove.

1 Select Tools > Prune, or from the toolbar, click the Prune (delete)

Leaf/Branch Mode icon .

The Phylogenetic Tree Tool is set to prune mode.

2 Point to a branch or leaf node.

For a leaf node, the branch line connected to the leaf appears in gray. For a
branch node, the branch lines below the node appear in gray.

Note If you delete nodes (branches or leaves), you cannot undo the
changes. The Phylogenetic Tree Tool does not have an Undo command.

3 Click the branch or leaf node.

The tool removes the branch from the figure and rearranges the other
nodes to balance the tree structure. It does not recalculate the phylogeny.

Tip After pruning nodes, you can redraw the tree by selecting Tools > Fit
to Window.
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Zoom In, Zoom Out, and Pan Commands
The Zoom and Pan commands are the standard controls for resizing and
moving the screen in any MATLAB Figure window.

1 Select Tools > Zoom In, or from the toolbar, click the Zoom In icon .

The tool activates zoom in mode and changes the cursor to a magnifying
glass.

2 Place the cursor over the section of the tree diagram you want to enlarge
and then click.

The tree diagram doubles its size.

3 From the toolbar click the Pan icon .

4 Move the cursor over the tree diagram, left-click, and drag the diagram to
the location you want to view.

Tip After zooming and panning, you can reset the tree to its original view,
by selecting Tools > Reset View.
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Select Submenu
Select a single branch or leaf node by clicking it. Select multiple branch or
leaf nodes by Shift-clicking the nodes, or click-dragging to draw a box around
nodes.

Use the Select submenu to select specific branch and leaf nodes based on
different criteria.

• Select By Distance — Displays a slider bar at the top of the window,
which you slide to specify a distance threshold. Nodes whose distance from
the selected node are below this threshold appear in red. Nodes whose
distance from the selected node are above this threshold appear in blue.

• Select Common Ancestor— For all selected nodes, highlights the closest
common ancestor branch node in red.

• Select Leaves — If one or more nodes are selected, highlights the nodes
that are leaf nodes in red. If no nodes are selected, highlights all leaf
nodes in red

• Propogate Selection— For all selected nodes, highlights the descendant
nodes in red.

• Swap Selection — Clears all selected nodes and selects all deselected
nodes.

After selecting nodes using one of the previous commands, hide and show the
nodes using the following commands:

• Collapse Selected

• Expand Selected

• Expand All

Clear all selected nodes by clicking anywhere else in the Phylogenetic Tree
Tool window.

Find Leaf or Branch Command
Phylogenetic trees can have thousands of leaves and branches, and finding a
specific node can be difficult. Use the Find Leaf/Branch command to locate
a node using its name or part of its name.
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1 Select Tools > Find Leaf/Branch.

The Find Leaf/Branch dialog box opens.

2 In the Regular Expression to match box, enter a name or partial name
of a branch or leaf node.

3 Click OK.

The branch or leaf nodes that match the expression appear in red.

After selecting nodes using the Find Leaf/Branch command, you can hide
and show the nodes using the following commands:

• Collapse Selected

• Expand Selected

• Expand All

Collapse Selected, Expand Selected, and Expand All
Commands
When you select nodes, either manually or using the previous commands, you
can then collapse them by selecting Tools > Collapse Selected.

The data for branches and leaves that you hide using the Collapse/Expand
or Collapse Selected command are not removed from the tree. You can
display selected or all hidden data using the Expand Selected or Expand
All command.
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Fit to Window Command
After you hide nodes with the collapse commands, or delete nodes with the
Prune command, there can be extra space in the tree diagram. Use the Fit
to Window command to redraw the tree diagram to fill the entire Figure
window.

Select Tools > Fit to Window.

Reset View Command
Use the Reset View command to remove formatting changes such as
collapsed branches, rotations, and zooms.

Select Tools > Reset View.

Options Submenu
Use the Options command to select the behavior for the zoom and pan modes.

• Unconstrained Zoom — Allow zooming in both horizontal and vertical
directions.

• Horizontal Zoom— Restrict zooming to the horizontal direction.

• Vertical Zoom (default) — Restrict zooming to the vertical direction.

• Unconstrained Pan — Allow panning in both horizontal and vertical
directions.

• Horizontal Pan— Restrict panning to the horizontal direction.

• Vertical Pan (default) — Restrict panning to the vertical direction.

Window Menu
This section illustrates how to switch to any open window.

TheWindow menu is standard on MATLAB interfaces and Figure windows.
Use this menu to select any opened window.
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Help Menu
This section illustrates how to select quick links to the Bioinformatics
Toolbox documentation for phylogenetic analysis functions, tutorials, and
the phytreetool reference

Use the Help menu to select quick links to the Bioinformatics Toolbox
documentation for phylogenetic analysis functions, tutorials, and the
phytreetool reference.
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A Examples

Introduction
“Using Spreadsheet Link EX with Bioinformatic Data” on page 1-22

Sequence Analysis
“Example: Sequence Statistics” on page 2-2
“Example: Sequence Alignment” on page 2-18

Microarray Analysis
“Working with ExpressionSet Objects” on page 3-2
“Working with ExptData Objects” on page 3-7
“Working with MetaData Objects” on page 3-11
“Working with MIAME Objects” on page 3-17
“Working with DataMatrix Objects” on page 3-21
“Example: Visualizing Microarray Data” on page 3-27
“Example: Analyzing Gene Expression Profiles” on page 3-51

Phylogenetic Analysis
“Example: Building a Phylogenetic Tree” on page 4-3
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